Vera Plus wifi: all your gateway belong to us

My local WiFi setup: A Comcast router ( provides DHCP internal IP addresses (starting at I have an AirPort Base Station ( providing the wifi. There are 2 Airport Expresses (.3 and .4, in Bridge Mode) extending the wireless signal.

My personal desktop has a static IP below the DHCP pool range. It is configured as “Using DHCP with manual address,” and manual address is The “router” (gateway) field is set to (which correctly points to the Comcast router).

I set up my Vera Plus pretty effortlessly. The Net & WiFi setings were on “Automatically configure.” It got a DHCP address from the router: All works well.

The next time I rebooted my desktop, some weird things started happening. I could no longer VNC to that machine from the outside world, which I would do regularly. That was the tip-off. I double-checked my desktop IP address: still

Then I noticed that under the “Router” (gateway) settings, it now said (the address of Vera)!

Initially, I didn’t realize that Vera was not only capable of connecting to WiFi, but was also providing WiFi. I certainly don’t need that functionality, so I switched Vera to “Manual” network mode, and turned off the WiFi providing. (“WiFi on” => “no”). I have “DHCP Server”=>“off”. Under “What Network Connection Type do you have?” I have “DHCP” selected, and it reflects the address, and the gateway as (as it should be).

Given those settings, why in the hell would my desktop machine automatically think that is my gateway? This happens across reboots. It ignores the machine (which SHOULD be the only DHCP server in the area), and goes straight to the Vera’s IP address.

To make matters worse, on rebooting my Airport Expresses, one of them followed suit, claiming as its gateway. It’s as if the Vera insists on being the alpha gateway of the pack.

I’ve had to drop the “Using DCHP…” notion, and switched to full manual mode, and that’s been OK.

But clearly the Vera seems to be broadcasting some sort of “Hey, I’m a internet gateway!” signal that it shouldn’t be.

Any ideas on running this down?

Your issue sounds like an old problem where the Vera DHCP server remains running and misconfigured on Vera, despite being turned off. Try running these commands in a ssh session to properly disable all DHCP service functionality and let us know if it resolves your issue.

I’m also curious about your network setup. Is your affected PC connected to the same switch as Vera and the cable router, or are there multiple switches? Essentially, I’d like to know where the router is, the PC, and Vera. Also, is the cable router’s LAN interface operating at a different speed than the rest of your affected network devices? I’m trying to figure out why only some few Vera users experience this issue and not everyone.

Hmm. The mystery deepens. First, more background:

The Comcast router does not provide WiFI. It has 4 ethernet ports.

[ul][li]I have one server connected by ethernet to the router (with a public IP address).[/li]

[li]I have one AirPort Base Station connected by ethernet to the router.[/li]

[li]My Vera Plus is connected by ethernet to the Comcast router.[/li][/ul]

All other machines and devices in the house, including my desktop machine, are connected to the WiFi provided by the AirPort.

Now, I SSH’d into the Vera Plus, and checked the dhcp settings (they were the opposite of what we want, as expected).

So I executed

[code]cd /etc/config

uci set dhcp.wan.force=0

uci set dhcp.wan.ignore=1

uci commit

/etc/init.d/network reload[/code]

And I confirmed that those stuck:

root@MiOS_50002141:/etc/config# uci show dhcp dhcp.@dnsmasq[0]=dnsmasq dhcp.@dnsmasq[0].domainneeded=1 dhcp.@dnsmasq[0].boguspriv=1 dhcp.@dnsmasq[0].filterwin2k=0 dhcp.@dnsmasq[0].localise_queries=1 dhcp.@dnsmasq[0].rebind_protection=1 dhcp.@dnsmasq[0].rebind_localhost=1 dhcp.@dnsmasq[0].local=/lan/ dhcp.@dnsmasq[0].domain=lan dhcp.@dnsmasq[0].expandhosts=1 dhcp.@dnsmasq[0].nonegcache=0 dhcp.@dnsmasq[0].authoritative=0 dhcp.@dnsmasq[0].readethers=1 dhcp.@dnsmasq[0].leasefile=/tmp/dhcp.leases dhcp.@dnsmasq[0].resolvfile=/tmp/ dhcp.lan=dhcp dhcp.lan.interface=lan dhcp.lan.start=100 dhcp.lan.limit=150 dhcp.lan.ignore=0 dhcp.lan.dynamicdhcp=0 dhcp.lan.force=1 dhcp.lan.dhcp_option=option:dns-server dhcp.lan.leasetime=60m dhcp.wan=dhcp dhcp.wan.interface=wan dhcp.wan.dynamicdhcp=0 dhcp.wan.dhcp_option=option:dns-server dhcp.wan.force=0 dhcp.wan.ignore=1

Attempt #1: So I tried returning my desktop settings to “DHCP with Manual Address” and re-inited the network.

As before, it located my gateway at! Argh!

Now, I noticed in the output above that the dhcp.lan settings are not the same as the wan settings I updated (i.e. dhcp.lan.force was 1, .ignore as 0, etc). And I see that the Vera is set to start the DHCP range at .100. So I figured I’d run a test to see whether that was significant.

Attempt #2: I changed my settings from “DHCP with manual address” to plain “DHCP” to see if it would in fact get a .100 or higher address. After changing that setting, I hit “Renew DHCP lease” to see what effect that would have, before rebooting the interface.

Strangely enough, clicking “Renew DHCP lease” caused the gateway to change to, as it should be! It even kept the I had entered manually.

At this point, I set my desktop back to “DHCP with manual address,” and it stayed with connected to

I rebooted my desktop interface several times to confirm that it sticks, and so far so good. I’m not sure why “Attempt #1” didn’t work at first, but it seems like things are now working as expected.

Networking, grumble grumble.

Thanks for the pointer!