Vera Plus requesting FW update from 1.7.4453 to 1.7.4833 (What and Why?)

Logged into my Vera Plus today and it is requesting a FW update from 1.7.4453 to 1.7.4833.
When I review the release notes it is titled “UI7 - Beta Software Update - VeraProtect - Version 7.0.30 (1.7.4818/1.7.4819/1.7.4820) - November 12th, 2019”.

First I don’t want to take a Beta FW update.
Second do I need this update to stay on path for future releases?
Third - Just a Note: I’m not really interested in VeraProtect. I bought Vera because there was no subscriptions.

Thanks for any insight!

It’s not the beta it’s the full release I believe

Its very strange - when you click on the link for the release notes Release notes for 1.7.4833 the page it takes you to is entitled “UI7 - Beta Software Update - VeraProtect - Version 7.0.30 (1.7.4818/1.7.4819/1.7.4820) - November 12th, 2019”. I for one will NOT be updating until it is clarified that this is actually a FULL (not beta) release.

Update: When I checked this morning (07:45 GMT 21 Nov 2019) it appears that the release notes were updated about 1 hour after my initial post. Now entitled “UI7 - Vera Software Update - VeraProtect - Version 7.0.30 (1.7.4832/1.7.4833/1.7.4834) - November 20th, 2019” and contains more information than previously.

Here’s an email they sent out today saying that 7.30 was released today

The only way it will come up on your vera is for it to be an official release. Likely the release note is not yet ready so that’s why you get forwarded to a previous beta release note. I think it should be fixed shortly.

Just caution about this firmware as it is a major change, updating the kernel of the OS, not just the vera specific firmware and is not something that is fully reversible. It has a lot of major fixes but also some odd bugs coming with it which I don’t know if they were fixed. Maybe best to wait for some positive report before upgrading.

I have the same link. Not touching it. Never saw the official release.

Feels like another gun jump?

Any news on the Extroot?


1 Like

Well, I decided to bite the bullet and try this out. Not coming back up. I have a support request in and awaiting a response. I can SSH into my VP, so not bricked, but also not working.

My advice would be to hold off on this one.


I’m in the same boat. I don’t usually jump on the latest … for just this reason. Oh well.

1 Like

Same here, only power light on. 403 forbidden on trying to access via browser. I’ve tried a hard reset through ssh but no luck.

1 Like

Yeah, count me in - hosed my Vera Plus that was perfectly running 7.30 Beta.

1 Like

this update broke my veraplus.
now reset to factory, remove controller from acc, then add it again…

micasa’s programmers are dumb and dumber

1 Like

BTW, I normally don’t jump on the new firmware the minute it gets released, but figured my Vera was already running 7.30 Beta successfully, what could possibly go wrong upgrading to the official 7.30? I guess anything and everything can go wrong…

Hard reset via ssh worked for me. Just restoring from backup now.

Did the same Upgrade and my vera was unavailable.

Customer Support suggested clicking 3 times on the reset switch on the vera, and then it reloaded. I reinstalled the backup, and everything is like before.

@Beefy can you provide the exact command you used to hard reset your Vera through ssh? I can still ssh to my unit. BTW, just above you mentioned you couldn’t hard-reset it, so did you have to do it multiple times? Thanks!

see my reply, no need to ssh

/usr/bin/ all

Only did it once then waited around 10 minutes to be able to connect via browser.

1 Like

Sad Project management. Why flip the switch before the docs are readied.
Thanks for the notes on taking this upgrade seriously.

So my controller just came back online - but I needed to restore the settings to put it back to it’s static IP settings. I don’t know if that was due to the support ticket or it just did it on it’s own.

Scratch the set the IP – did it in the router and rebooted the VP.

Interesting: You are running the latest version 1.7.4833 (7.30)

Ran “/usr/bin/ all” 15-20 minutes ago, keeps blinking Power LED and still not come up. Do I need to power cycle it manually?