Vera Plus - only power light on

I received my Vera Plus today. I plugged in and went to the URL to configure. The setup found my device and I proceeded. It stated it was updating software for awhile then went to state that had a button to go to the ‘Dashboard’. When I clicked on the link it took me to my dashboard and I could see my device was now showing offline. When I look at the Vera Plus I only have a power light on. NO other lights. I unplugged and plugged back in and still only the power light. It still shows offline. Anyone see this issue? Thanks in advance! Nate

This Might help had nearly the same problem.
Power the device push a paper clip into the front hole (to the right of the 2 buttons) while the power is on the light will flash, then hold it for a few seconds (5 or so) then let it boot up.

This might resolve the problem

Hope it helps


Thanks for the reply Mick. I did receive a response from tech support stating to try and set the unit back to factory by clicking the reset button 6 times within 6 seconds. They stated the power LED will begin to flash and within a few minutes it should be completed. My power LED flashes and the Internet LED goes solid. I left it in that state all day yesterday to no avail. I tried the process again with the same results. I’ve replied to support with no response and also called and left a voice mail with no response. This is very frustrating now. :frowning: Thanks again for your response though!

I tried both, holding reset in for 10 seconds and your 6-presses. Neither has helped. Mine’s stuck with a LUUP Engine taking too long error. I’ve posted details here.

I have exactly the same problem with none of the proposed fixes working. Did any of you figure it out?

Tried clicking the reset switch with a pin 6 times. Resulting in either with the power-light blinking or the internet, in either case it didn’t start working. Running out of options. Waiting for customer care to respond.

So, anyone else had any luck? Don’t see many reports of this out there so did I get a faulty unit?

Got response from Vera, they handled it very quickly so props for that. Turns out the internal memory is defective, meaning I have to replace the unit. Just to let others know if there is a similar problem.

I appear to have the same problem. Started troubleshooting with Vera tech support on Friday. No combination of reset button pushes seems to have an affect other than changing the lights. Can’t see the Vera on my internal network nor is it accessible through - unit is reported as “offline” after adding it manually.

If I find a solution with support on Monday, I will post back, but as of now it looks like the unit is going back.

Same error here.
Got it today and very eager to setup and go, but no luck :-\

I have the same problem. Has anyone had any success in sorting this out? Very frustrating.

Have you tried the reset? Do you have a blinking internet light?


I have this problem after attempting an update. The instructions on the screen indicated that I should wait 15 minutes and if the unit didn’t come back online, I should unplug power and plug it back in. I still have nothing. I tried deleting the controller and adding it back and nothing. I now just have a solid power button.

Where can I find the manual? I have a VeraPlus-US

I got my first VeraPlus three days ago, and I had the same problem. Also tried to reset the device in many ways, to no avail. But in the end, I fixed it, so I post my solution here in case it might help someone else.

Small detail: even though the power light was the only one on after apparently updating, it was not always solid: it was solid only right after being plugged in; after a short while, though, it started flashing rapidly. But still, no other light would come on.

SO, here was my process (if your problem is the same as mine, you won’t have to do all this stuff – go to the end to know about a relatively easy fix):

  • I noticed my router was leasing an address to the unit, and also that the unit SSIDs (both 2.4 and 5 Ghz) were visible, so I guessed it was not really bricked and that something could be done with it.

  • Attempts to SSH into the device using the router-leased address failed (knowing what I know now, I’m not sure why, though).

  • Instead of my router, I plugged the unit to a Linux laptop instead, which I configured as a DHCP server + gateway to try to figure out what was going on. It leased an address to the VeraPlus, and… I could SSH into it! First victory. We have to wait a little while after bootup, though, for the SSH server to come up (maybe 1 or 2 minutes)

  • While connected by SSH, I checked the unit logs, and I found out that it failed at downloading a squashfs from a MiOS server, because it could not resolve the address. I checked, and the address was good, so what was wrong?

  • I realized the VeraPlus could not actually resolve any URL. Running ifconfig gave me the answer to all my problems: there was an internal NIC configured with the IP… Which is also the address of my router, and of course my gateway, AND my local DNS! (That could also explain why, when the unit was on, some of my network devices had weird connection problems…) So I reconfigured my Linux DHCP server to serve a different DNS address than and… Bingo!!! Upon restarting, the VeraPlus completed the update process, all lights turning on one after the other, and voilà!! It became alive and kicking!! :smiley: :smiley:

  • After the update seemed finished, I SSHed into the unit again, and the problematic NIC had changed its address to, which was expected from its MAC address finishing by D8:BC, so I could plug it back to my router, and so now everything is fine! :smiley:

SO, quick fix: if you ever encounter this problem, check if your router IP address is (which is a very common router IP address); if it is, change it for something else (refer to your router instruction manual to know how to do this), and it might just fix your problem.

1 Like

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules