Vera Plus Fourth Reset Zigbee

Hello Vera Support,

I bought a vera plus for the local control without requiring an internet connection. I’ve constantly thought to myself as I’ve attempted to work through the the configuration process, “Am I foolish for believing that consumer level home automation is reliable?” at this point I believe I have been.

I work for an IT support organization supporting OpenStack and understand how ridiculous some {customer support,customer} requests can be. I have tried to exhaust all possible solutions before coming to the forums to vent my frustrations with the exception of emailing for a support request which is the point of this post (to share the pain). I realize support requests are initiated via email but feel that others need to read my experience with the Vera Plus and Zigbee devices, specifically the GE Link Smart LED Light Bulb, A19.

I’ve spent a lot of money and time attempting to get my home automation working with motion sensors and lights. I didn’t purchase all of this upfront, I started with x2 GE Link Smart LED Light Bulb A19 which have a 9 out of 10 compatibility rating with the Vera Plus and a single GE smart z-wave motion sensor. During my first week or so these worked wonderful, zero issues for 7+ days straight.

Certified Partner Products ** 9/10 compatibility rating with the Vera Plus **
Model Number: LED-A19

http://getvera.com/portfolio-posts/ge-link-led-bulb/

These are the second gen “Daylight” models and appeared to work great initially however the more Zigbee devices I added to my Vera Plus the more unreliable the entire system has become. At this point (where I went wrong) I assumed that the Vera Plus was stable using Zigbee devices / GE Link A19 bulbs and order an additional 9 bulbs from Amazon plus a host more Zigbee/Z-wave devices.

I believe I’ve foolishly purchased the additional equipment after my first week test. The total purchase consisted of x11 GE Link A19 bulbs along with x4 Ceralite 2nd generation motion sensors, x2 Ceralite door/window sensors, x4 z-wave GE smart motion detectors, and x2 z-wave GE smart dimmers. The z-wave stuff is bullet proof and works amazing (lesson learned) the Zigbee brings my entire system down constantly.

First Reset:
All devices setup at this point I was not aware of the backup feature and not having switch guards on my GE Link Zigbee bulbs my wife out of habit flipped some of these bulbs causing them to stop being detected. Flipping the switches manually didn’t seem to do anything, rebooting the Vera Plus didn’t seem to do anything, nothing worked.

Second Reset:
After researching Zigbee wireless protocols, I’ve reset the Vera Plus and attempted to added everything from scratch. I initially thought possibly my 2.4 GHz Wi-Fi was interfering with the Vera which I have setup on a isolated vlan for IoT devices so I disabled the 2.4 GHz ssid and tried again.

No dice, the next morning various GE Link A19 bulbs were dropping off the Zigbee network causing none of the Zigbee GE Link A19 bulbs or sensors to work properly. I figured possibly my Zigbee network layout wasn’t meshing well with z-wave.

Third Reset:
I’ve re-mapped my GE Link A19 bulbs, other Zigbee devices and z-wave products to introduce better isolation between the messed ** supported ** Zigbee / Z-wave networks following best practices for both protocols. On this third reset I came across the Vera z-wave backup / system backup feature to save your devices.

I ensured that only devices were being added to a factory reset Vera Plus and no scenes were running. Once I had all 25+ devices paired with the Vera Plus I backed everything up. I tested everything to ensure it was working.

Shortly after the backup I experienced the same behavior as the previous two attempts. After a few hours the GE Link A19 bulbs randomly drop off the Zigbee network and it appears to cause everything else Zigbee to have cascading failures, not fun.

Fourth Reset:
Factory reset > Z-wave / server backup. Everything worked for about 8 hours then again a GE Link A19 bulb stopped being detected causing cascading failures. My experience has been a misadventure through insanity and I’ve payed good money for it unfortunately. This is why I “chose” to publicly voice my experience on these forums with the Vera Plus inside of silently emailing support. Here is a chance for the Vera Support team to evaluate this post making it public, my good will or sorts before blogging about it much much more detail.

Thanks,

vid

Screenshot showing my fourth reset status

Vera Plus + Zigbee failures:

Vid, thank you for posting your experience with the GE A19 bulbs. I have had the same experience with the 10 bulbs I purchased. Unfortunately I gave up and have started to replace the bulbs with z-wave. My GE bulbs now just act as regular switched lights.

I hope the handling for these bulbs gets better on the platform so cascading failures don’t happen due to connectivity loss on a single light.

I have had a LOT of experience with this exact problem.

Not long after I got my Vera Plus, I ran across a deal at Home Depot where they were practically giving these bulbs away at $25 for a set of two with a tiny Link hub. Basically, it’s this set that’s available for $75 on Amazon. I considered the Link hubs as kind of a throwaway bonus and chucked them in a drawer, thinking I’d never use them. I think I wound up with 12 of these Zigbee bulbs spread throughout my house. They seemed to work great for a short time, but it didn’t take long for chaos to ensue.

Since my setup was so heavy in these bulbs (I just had a few actual Z-wave devices at first) I just thought that the Vera itself was unstable. It didn’t take me too long to figure out that it was the combo of these GE A19 Zigbee bulbs and the Vera Plus. Sometimes, there is a tangible reason for why they will suddenly go offline/corrupt, like someone accidentally shut off the power to one of them. Sometimes, it just seems to happen randomly. One of the bulbs will seem to go missing completely in the config, or it will show up with it’s factory configuration and the Vera Plus will go into reboot loops. When it does this, the Vera Plus will still sort of work, but with HUGE lag. The only fix is to track down the affected bulb and remove it from the controller, factory reset any affected bulbs, then re-add them. Unfortunately this also removes them from any scenes, and they have to be re-added with their new device ID.

The most spectacular failure I experienced with these happened a couple of months ago. I was up really late on my computer one night. It was about 2:15 AM, when I noticed that a couple of lights had turned themselves on when they shouldn’t. In checking a little further, I noticed that every single GE A19 Zigbee bulb inside the house and out, had turned themselves on, full brightness and were suddenly showing as missing in the controller! Fortunately, I didn’t have any of them in anyone’s bedrooms. I tried everything, including restoring from multiple different backups, but eventually, I had to factory reset every bulb, remove their definitions from the controller and recreate all of it.

At that point I decided to make as many of the GE bulbs as possible go away. Clearly, the 9 out of 10 compatibility rating is “flawed”.

I have been replacing these bulbs with literally anything else, and the stability of the controller increased dramatically. In the course of dealing with this, I’ve also found a way to make them stable, but it requires a bit of extra hardware…

Remember those “Link” hubs that came with the GE A19 sets I got that I chucked in a drawer? I got the idea to use them as intermediaries. It turns out that the Link hubs are basically slightly dumbed down Wink hubs that only work with the GE bulbs. As such, they are compatible with the Wink plugin/app for VeraPlus. So I’ve removed the remaining GE A19s from the Vera Plus. Then I set up one of the Link hubs and added them to that. Then, using the Wink plugin, I pointed the VeraPlus at the Link hub, and it enumerated the bulbs. They show up in the Vera almost as they did before, but they have been 100% stable ever since! I suspect that if you do the same with a full Wink hub, if you have one laying around, or can get one cheap, it will act the same way.

So now I just use the link hubs as satellites, each controlling a few GE Zigbee bulbs in different physical areas. This also has a couple of other added benefits. You can use the Link/Wink hubs sort of like range extenders, since the bulbs talk only to the Link, and only the Wink/Link talks to the Vera. It also gives you another way to control those bulbs if the Vera goes offline for some reason.

The only real downside I’ve found to this is that you see maybe a second or two of extra delay when interactively controlling the bulbs from the Vera, I guess since the commands have to cascade between the two controllers. I can live with that.

The only other thing is that it can be a bit tricky to get the off/on state synced up between the link and the Vera Plus at first. Sometimes, the Link will think a bulb is off when the Vera thinks it’s on, and flipping the “switch” will just invert the states between the two. The plugin/app has ways of helping you get past this though, and it’s only really been a problem for me when first setting a couple of them up.

This sounds kludgy, but it works surprisingly well.

We feel your pain!

[quote=“vidurous, post:2, topic:194822”]Screenshot showing my fourth reset status

Vera Plus + Zigbee failures:
http://i.imgur.com/0oqHE1J.png[/quote]

Same exact problem here. In my case however they are Cree standard dimmable bulbs.

Installed everything 2nd weekend in January. I upgraded to the Alexa required firmware on February 1st.

On February 15th every single zigbee device cascaded failure off sometime randomly around 10AM while I was at work. I contacted support they said to delete everything and re-add it. I had already seen this thread and, well, I manage an IT department and I am a bit of a troubleshooter so this did not sit well.

I did it anway on the morning of February 16th, deleted everything, fixed my scenes, fixed Alexa, etc.

Went to bed last night on the 18th and lights would not go off. Checked the alert, they have been offline since around 8AM on the 18th. Barely 48 hours. Needless to say this is not working. How can a cascading failure like that even happen? (rhetorical question). No power failures here, nobody turned any bulbs off.

Anyhow, came here to voice my concerns before I start slagging this on Amazon where I bought it. Supports suggestoin to delete everything is not an option and only worked for 48 hours. Argghh.

I put in a used Wink Hub that I bought off Kijiji half price!

So far, 48 hours and going strong.

Super kludgy that I have to use the Wink Hub, but it is working. If only the Wink would work with the DSC EVL-4… then I would retire the VeraPlus until they get around to fixing it.

Well, I know it doesn’t help much, but it may make you feel better to know you guys are not alone.

I’ve been wrestling with what seems to be the same ZigBee issues for about 2 months. I have half a dozen GE Link lights which used to work perfectly on a Wink Gen1 hub, reset and re-paired as “Generic Zigbee Device” to VeraPlus running latest UI7 (problem has existed for all the versions since the box was purchased). After a day or two they start being flagged as “can’t detect device”, though still operating; after another day or two all the lights are ON, completely unresponsive to VeraPlus commands, and flagged as “can’t detect device”

I eliminated all other 2.4Ghz devices except my Philips Hue Gen2 hub. I added an Iris Smartplug as a ZigBee repeater. I added another lightbulb in the middle of the house to act as a repeater. I removed, reset and re-paired every light AND the repeater; to no avail. For about 3 days everything worked well, then a Vera Restart occurred (notified via VeraAlerts) and … all the ZigBee devices were offline again.

My installation has 30+ Zwave devices, all of which seem to work reasonably well. It’s just the ZigBee bits which consistently break.

I just got off the phone with Vera Support; they had me turn on Verbose Logging and Lock Log Levels; I’m about to remove/reset/re-pair all the ZIgBee devices, and after they fall offline again I’ll contact support with the date/time, so they can examine the logs and hopefully get to the bottom of this problem. I’ll report back here if/when I have any more news.

I would create a script that runs every couple of hours …
In the script I would put one line like the following, one for each Zigbee device:

luup.set_failure(false, ZigbeedDeviceID)

If they get any communications error they shut down … the above will reset the error.

[quote=“RichardTSchaefer, post:9, topic:194822”]I would create a script that runs every couple of hours …
In the script I would put one line like the following, one for each Zigbee device:

luup.set_failure(false, ZigbeedDeviceID)

If they get any communications error they shut down … the above will reset the error.[/quote]

Richard, good to hear from you!

I do have failure-reset lua code in my Startup lua, but I’m not ready to put it in a cron job yet. Thing is, these ZigBee devices simply shouldn’t be doing what they’re doing. Resetting their Vera failure flags isn’t going to solve the problem – only mask it. This never happened while the lights were paired to the old gen1 Wink hub, managed with Vera Wink Plugin; they only fall offline when paired with VeraPlus. And when they go, it’s one-after-another in rapid succession, until they’re all offline, and nothing I can do (restore from backup, etc) will bring them back – except to remove them all and re-pair them. This is definitely not the desired or expected behavior.

I removed all the ZigBee devices about 6 hours ago, reset them, and re-paired them with Vera, with Verbose logging and Lock Log Levels checkboxes set (per instructions from George at Customer Care). Right now, the devices are all still online and functioning normally. They typically don’t fall over for a day or two; I’ll report back whenever I have some news :slight_smile:

FWIW I see some of these starting to creep into the logs:

02      03/03/17 23:36:49.223   ZigbeeCommand::HandleResponse Wrong sender, expecting: 0x9cba, received: 0x063a

02      03/03/17 23:38:46.186   ZigbeeCommand::HandleResponse Wrong sender, expecting: 0x9cba, received: 0x38e6

02      03/03/17 23:38:46.865   ZigbeeCommand::HandleResponse Wrong sender, expecting: 0x9cba, received: 0xdf33 

02      03/03/17 23:40:49.350   ZigbeeCommand::HandleResponse Wrong sender, expecting: 0x38e6, received: 0x9cba

May, or may not be significant…

Update: I deleted all my ZigBee devices (5 GE Link Lights, and an Iris SmartPlug); physically reset them to unpaired status; and re-added them all to VeraPlus (most recent public firmware release), at about 6pm on March 3rd. FWIW, this is about the 12th or 13th time I’ve performed a “full reset” of the ZigBee stuff.

All appeared to work perfectly well for about three days. Then the problems began (again); the lights started showing up in “Can’t Detect Device” status in the Vera UI, and were either non-responsive or slow to respond.

After 7 days, at about 10am on March 10th, the VeraPlus restarted, all the GE Link lights came on spontaneously, and remained on (as they would in the case of a power failure, though the power has not glitched in the slightest).

I have eliminated all potential sources of interference – though I wasn’t worried about it to begin with, since my Philips Hue Gen2 bridge controls 15 or so Hue devices without issue using ZLL; the GE Link lights worked perfectly well when they were paired with a Wink hub and controlled by Vera via the Wink plugin; and there haven’t been any new components added to my system.

During the week-long testing period my system had “Verbose Logging” and “Lock Log Levels” turned on at the behest of the tech support guy I spoke to around 5pm on March 3rd. Hopefully they captured everything necessary to troubleshoot, diagnose and solve the problem… but I don’t know if they do or not, because of course I don’t get to see MY OWN logs [sub](without some unauthorized hacking)[/sub]. They are scarfed up by the RotateLogs.sh script, uploaded to MiOS, and deleted from my system every few minutes – and we mere mortals don’t have access to the logs wherever MCV stores them, which is one of my many annoyances with their business practices. >:(

I submitted a trouble report via the VeraPlus UI “Customer Care” panel yesterday (about 30 hours ago). I didn’t receive any confirmation “we got your email and we’ll get in touch” message; no trouble ticket number; no acknowledgement of any sort. Hopefully that doesn’t mean I’m just being ignored, and that the tech support folks will get around to doing something someday, but that’s another one of my many annoyances with MCV’s business practices; it’s difficult to have realistic expectations of what to expect from their support mechanisms when no expectations are set in the first place. >:(

So, all my lights are still on, and have been for about 2 days straight, because I don’t want to turn them off and potentially contaminate the logs with confusing messages, change the ZigBee mesh network dynamics, or otherwise hamper the forensic effort I’m hoping is going to be underway very soon. :-\

I’ll update again if/when I hear from support.

Update: got the following response from support:

We?ve gathered multiple log files from different networks that we?ve sent for further investigation to our development team. We are aware of this issue where the ZigBee devices fell off the network and wanted to assure you that we are working aggressively on fixing it. What we?ve noticed is that the devices reset themselves and therefore become unresponsive.

I?m afraid that the only solution at this point is to reset the devices when losing the connection and then re-add them.

Well, another solution would be putting the devices back on the Wink hub where, if the devices did ever “reset themselves”, it was totally transparent to me, and never affected the operation of my home automation system in the slightest :stuck_out_tongue:

I don’t have any of these bulbs but just want to share some experience from a neighbor who is on ST.
The issues you are seeing are not related to the Vera. ST which arguably has better Zigbee support also has catastrophic issues with the GE bulbs.
My friend ended buying a cheap Hue hub to use as a Zigbee bridge for the GE bulbs. You can do the same with the vera. My understanding is that it not only stems from the difference in zigbee stack between light bulb and HA but there is something about these bulbs which makes them drop from most networks. Zigbee is flawed by design in that there is not quite any standard stack protocol like zwave. Every supplier is customizing his own and although it is getting better now, it is not quite where zwave is yet. I have yet to find a single zwave device I was not able to make work with the vera granted I may have had to do some custom user config on the device or on the vera. Zigbee on the other hand…

Sorry to bump an old thread, but this seemed the best place to ask my question:

Years ago I bought a discounted Home Depot Wink Hub (Gen 1) and 3x GE A19 led bulbs. These bulbs worked perfectly with the Wink Hub but I wanted a more flexible system that would run locally so I got a Vera Plus.

When attempting to migrate these bulbs to the Vera Plus I’m not even getting as far as anyone else in this thread as they do not appear as an option under the “Add Device” option. A few other threads seemed to suggest they used to on the “Add Devices” list i.e.

Can someone confirm that these bulbs have been removed from the firmware 1.7.4970? They did not respond to the 'Generic Zigbee device" option either.

Since the Wink app is no longer available to drive the wink hub from Vera I’m guessing these bulbs are now junk?

1 Like