Vera Plus Downgrade Fails and Reverts to a Default Firmware

Hi everyone,

I am having trouble downgrading the Vera plus firmware.

Basically I have been using the Custom URL Download:

I got the URLS from the forum and have tried multiple versions. I am trying to get a firmware older than april 2017 in the Vera plus.

I tried this (obtained from the forum):



The thing is, every time I do the downgrade the Vera Plus for some reason reboots and reverts to version 1.7.3532. Which is the firmware that came from the factory. I even tried upgrading the vera plus to the latest 1.7.3831 and then downgrading using one of the above links, yet still after that process the vera goes back to 1.7.3532. I am doing this on 2 Vera Plus’s and I am getting the same results.

What is going on why cant I downgrade them. I was doing this with multiple vera edges before and it worked perfectly.

Any insight? Thank you.

Hi Just wanted to give an update that this issue was resolved after I contacted support. This was their response (leaving this post online to help anyone facing the same issue in the future):

Thank you for contacting Vera Support.

I?ve accessed the two controllers using the codes you provided and saw that they had the force upgrade flag set on them. This is why the firmware was updating automatically.
I?ve now removed that flag and you should be able to do the downgrade to the 1.7.2608 version.