Vera not detected by discovery

After having given up for a month or so, I tried to set this up again. I’m running on Linux, and have a Vera Plus. All devices are on the same subnet (vera is, ConciergeServer is, Google Home is Vera is running 1.7.* firmware, so UI7.

I’ve got the ConciergeServer up and running and put my login credentials in and choose UI6+. “Update & Restart” changes the contents of VeraProperties.jsonenc, but the only other effect is:

Feb 15, 2018 9:59:43 PM I:VeraConnect.VeraConnection:ClearCredentials
Feb 15, 2018 9:59:44 PM I:VeraConnect.VeraConnection:AddCredential:UI6 - REDACTED
Feb 15, 2018 9:59:44 PM I:VeraService:Create
Feb 15, 2018 9:59:44 PM E:CSWebContainer:handle:/Update?UpdateData=%5B%7B%22Name%22%3A+%22REDACTED%22%2C+%22Password%22%3A+%22REDACTED%22%2C+%22Type%22%3A+%22UI6%2B%22%7D%2C+%5D&Password= 
        at com.rtsservices.conciergeserver.SmartHome.StopPoll(
        at com.rtsservices.conciergeserver.VeraService.Stop(
        at com.rtsservices.conciergeserver.Configuration.ValidCmd(
        at com.rtsservices.conciergeserver.CSWebContainer.handle(
        at org.simpleframework.http.socket.service.RouterContainer.handle(
        at org.simpleframework.http.core.RequestDispatcher.dispatch(
        at java.util.concurrent.ThreadPoolExecutor.runWorker(
        at java.util.concurrent.ThreadPoolExecutor$

and then a series of periodic messages about:

Feb 15, 2018 10:00:07 PM V:CSWebContainer:Config Cmd:/Query?Discovered=

Neither the Google Home nor the Vera show up in the devices list. The ConciergeServer UI must have changed because I don’t have step 3 in “Debug your configuration”:

3. At the bottom of the local ConciergeServer configuration page click: [b]Update Vera Concierge Server Cloud Info[/b]

My UI is missing this link.



Same here. Any update on this?

Got it to work. Here are my steps.

  • unlink GH account if its already linked and log out of chrome
  • downgrade to the latest 1.x version
  • delete the current config (VeraProperties, VeraDatabase, keystore)
  • restart the server from the command line
  • insert your Vera cloud credentials (UI6+CaseSensitive). You should be able to connect and receive a token (new VeraDatabase file is created)
  • now you can upgrade to the latest 2.x version
  • DO NOT click “Update and Restart”
  • restart the server from the command line and refresh the browser
  • now you can click “Update Vera Concierge Cloud Info” and link your GH account

Good luck

I’m having the same problem. Where did you get v1 of the ConciergeServer.jar - I can’t find it.

I haven’t got a fully functional system myself yet, but I can help with that last question pshotton. The Vera Concierge server has a “Software Update” tab. There you can choose a version and update to it. I followed the instructions ramethema gave and they worked for me! After downgrading, both my Vera and my Google Home device were found. I quickly stumbled into some other problem (connectivity), upgraded back to the latest version and now also that worked.

My next step is to actually get Google to recognize “Talk to Vera Concierge” (“Sorry I can’t help with that yet” …)