Vera Mobile hasn't worked on Android 10 for over 6 months!

Will this ever get fixed or is it abandoned?

It ALWAYS tells me the credentials are wrong. I have verified creds, reset creds, cleared cache, cleared data, uninstalled and reinstalled, heck, I even got a new phone and still, same result.

I’m on the beta by advice of Vera engineers.

Couple of quick questions (just out of curiosity):

  • Does the problem persist whether your Android device is connected to the Web via WiFi (home network) or solely via Mobile Data (cellular provider network)?

  • Are you still able to log in properly with those same credentials on the Web UI of your controller?

Libra, I was going to check that and let you know but I guess that was the last straw and now my account is locked. I have put in a support ticket with Vera to get it unlocked. I will let you know when I can.

Interesting note though - I found the support ticket correspondence with Vera from months ago and realize that I also switched to an iPhone for a short stint and installed the Vera Mobile app there and got the same result. I think my account profile with Vera is corrupt.

1 Like

I’m having the same problem - unable to log into my Admin account with the last release version of the mobile app on Android 10, and with the last two version updates of the beta. I have no problem logging in to my Admin account via browser, and can login to the mobile app using an alternate, Advanced User account. I’ve not made any recent changes to my account.

I submitted a query to Support yesterday - still awaiting a response.

I get the same results via WiFi or using a cellular connection.

I think that I found what was causing the new login problem, that affects only the very recent Android app updates.

My official Username for Vera is, and always has been my Gmail address, which I have used for login everywhere, with no problem, until now.

Some months ago I designated my Email address for Notifications from Vera. That was never a problem until now.

I just discovered that I can log into the Vera mobile app, using my Email address, along with the same Password that I use for logging into Vera.

For reasons that are not understood by me, I can still login via a browser using my Gmail address/Password combo, as always, but when logging in on the current Android Mobile app, it rejects that same Gmail address/Password combo, but accepts the Outlook Email/Password combo. I don’t know if that odd login will cause other issues, or not at this point, but it really feels like a bug in the newer app versions.

Thanks for reporting this guys. Checking now.

Hi @vicw . Please share me in a private message your email/username, so we can check for database issues.

Has anyone had success using the Vera Mobile app to change the setting on a thermostat? I keep waiting for that functionality to be added, so I can raise our lower the temperature in my ecobee thermostat, linked to Vera Plus.

Currently, that device just shows up (as shown) under Devices and on the Dashboard as having no adjustable features. I don’t just want to know what temperature it is inside… I’d like to be able to control it!

P.S. The Vera Community Forum continues to have intermittent speed and connectivity issues; it took me TWO DAYS to post this message successfully, including the uploaded image. Ugh. Is the site also in beta?

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules