Vera Home Control (pebble app)

This is another pebble app for controlling your UI7 Vera. I started a new thread due to the request of another user. Any feedback and hearts would be greatly appreciated.

Version 1.2 should be live now which currently supports:
*All versions of watches (pebble, pebble time)
*lights (dimmer and binary, long press to immediately turn dimmer to 100% or 0%)
*Energy Monitors
*Remote and Local access

Future support will hopefully be:
*Screen shots from camera (looked into this a bit already and it’s looking less and less likely)
*Alarm panels
*Door locks

Please post any comments, bugs, feature requests, votes for features etc here.
Thanks all!


Thank you! I just downloaded it tonight and tested a light or two but I have to say it worked flawlessly. I’ll certainly give any feedback I can as I use it more.

Not working with IOS 9?
Empty screens on Pebble Time (lights,scene,…)

Not iOS 9 per se but maybe one of the updates. It worked previously but now I just tried and get a blank screen too. I tried to go into the app settings but I just get a spinning wheel. Don’t have time right now to investigate what happens when you delete and reload the app but will try in the future.

Yes, something happened and I’m not sure what. I have not done any updates and everything had been working for several weeks flawlessly. Sadly I don’t have the time to debug it right now, but in the next day or two I’ll try to make the time to see what’s causing the issues.

Thanks for bringing it to my attention.


Can you planning in the future under Vera UI5 ?
My Main system running Vera3 UI5 and the second system running Vera Edge UI7 with bridge mode.

slajgaj, Sorry I am not planning to support UI5. I do not have a system to test with UI5. I do plan on implementing a LAN only checkbox in the setting which will allow only direct access via LAN (you’ll have to enter the IP of the controller as well in the settings). I’m not 100% sure, but I think the luup requests I use to manage everything didn’t change from UI5 to UI7. I think (again, not sure, but think this is the case. Someone else feel free to chime in and let me know if my assumptions are correct) that the main difference and why it doesn’t currently work with UI5 is the login verification stuff. If that’s taken out though (direct access) then it should work. If that is the case once I get the LAN only mode in place you can use that mode to access the controller, but you will only be able to do so while connected to your wifi.

I tried the app again today and it worked. I’m not sure if yesterday vera was having issues, or my home internet connection, but it worked. Others who are having issues would you mind testing it again and let me know if it works? If nothing appears try clicking “save” in the settings menu on your phone. This will resubmit the verification stuff, and re-cache your lights. Thanks for any help.

Works today.

Yesterday I couldn’t even it save, it was just a spinning wheel on the settings screen.



In The luup reguest and lua schema not different in UI5
All app and http request work for me under UI5 and UI7
No different
Only different, the remote login. In the UI7 the remote access with token, under UI5 this login is a simple.

For example under UI5 the remote request:

Hi slajgaj,
I just post a new topic about how to make work that URL that you described in UI7.
I had something similar for UI5, but tried with UI7 and is giving me invalid password. I double checked password.
Maybe is the server that I’m trying to reach?

Yes would be great if you could provide the optiion to direct the login to:

MiOS (for UI5 users)


Login (for UI7 users)

The code is public on Github. I thought I posted a link already but I see I didn’t, sorry.

My only request is that people make merge requests with updates/changes/additions instead of releasing multiple apps in order to keep one awesome pebble app. I will happily give credit to any one who contributes to make sure that it’s not just my name appearing in credits.

Thanks for any help.

Hello, I’m trying out your app, but I just get the blank screen that others have mentioned before. Do you have any ideas to fix that issue?