Vera Edge - Won't respond - Dead?

So my Vera Edge continues to be the bane of my existence. I FINALLY took the step of moving my thermostats off of my old Vera 2 (Running an ancient but stable UI) and onto the Edge. Moved the downstairs thermostat yesterday, and the upstairs today. I also added 1 new dimmer switch. Once I was about to pair up the last dimmer, I went to plug my Vera Edge in to pair it. I plugged it in, and the Z-Wave, and Service lights light up, and the Internet light blinks about 3-4 times…then, within 5 seconds of being plugged in, all the lights go black. And then…nothing.

Anybody have any thoughts? This isn’t even an interface issue. It’s just dead. No lights at all. I’ve tried unplugging and replugging 2-3 times, on different outlets, etc. Same thing every time. ???

Humm…seems like it might be backing itself up or something. Has anyone experienced this?

[quote=“nas4a, post:2, topic:186578”]Humm…seems like it might be backing itself up or something. Has anyone experienced this?[/quote]Vera doesn’t “go dead” for backups.

If Vera powers on for a brief period and then powers off, my suspicion would be a bad power supply. Can you try a different power brick 12VDC 1.5amp or greater.

The other possibility is file(system) corruption causing a boot loop, but the power light usually remains on in this scenario.

Very odd…I tried to log into it via, and when I did, it kicked back on with all lights lit. I took it back upstairs to try another pair, and dead again…until I brought it back down, hooked it up to the net, and tried to access it via getvera again. Go figure. Well…it works right now, so I’m happy. This thing is so wonky though.