Vera Edge issues with RFXTRX - "ERROR: Device not ready"

I have a Vera Edge that I’ve been happily using with a RFXTRX USB device and the plugin (v1.0) for many months, but recently things have gone badly wrong.

The first thing I noticed was my ALTUI plugin no longer responds, and then even UI7 itself seems very erratic and if I try to login I just get a spinning disc where the interface hangs. The Vera support guys have logged in to do some analysis and said that there were lots of errors associated with the RFXTRX plugin, and that I should “reconfigure” it. Sure enough, all my RFXTRX devices seem to have disappeared and if I try to do make any changes in the plugin device config I get a “ERROR: Device not ready” message. I had it configured for LightwaveRF devices, an Owl energy sensor and 3 Oregon Scientific temperature / humidity sensors. The only recent change I’ve made was to configure the readings from the temp sensors to be uploaded to Thingspeak via ALTUI.

Can anyone suggest what the best way forward is? Is it possible that I have an issue with the hardware unit itself?


Check the RFXtrx with RFXmngr on a Windows system.


I’ve downloaded & run it against the device on a Windows PC and it seems to connect OK, though all the options are greyed out:

Reset receiver/transceiver
Get Status

Packettype = Interface Message
subtype = Interface Response
Sequence nbr = 10
response on cmnd = Get Status
Transceiver type = 433.92MHz
Firmware version = 67
Firmware Type = Type1
Transmit power = -18dBm
Hardware version = 1.0
Undec off
X10 disabled
ARC disabled
AC disabled
HomeEasy EU disabled
Meiantech disabled
Oregon Scientific enabled
ATI disabled
Visonic disabled
Mertik disabled
AD enabled
Hideki disabled
La Crosse disabled
FS20/Legrand disabled
ProGuard disabled
BlindsT0 disabled
BlindsT1 disabled
AE disabled
Rubicson disabled
FineOffset disabled
Lighting4 disabled
RSL disabled
Byron SX disabled
Imagintronix disabled
KeeLoq disabled
Home Confort disabled
RFU2 disabled
RFU3 disabled
RFU4 disabled
RFU5 disabled
RFU6 disabled
RFU7 disabled

Flash the latest firmware![/code]

Does that look OK? I guess I should flash the latest firmware as it advises. Is “RFXtrx433 Type1 Firmware” correct for me? Version 1005 seems drastically different to the v67 I have loaded!

The RFXtrx433 is OK. You can flash the latest firmware but if version 67 is all you need keep it.

USB power problems can put the USB FTDI chip in the RFXtrx in frozen state. Use a power USB hub with a quality power supply.

Thank you.

I’ll look to get a powered USB hub. I don’t have one spare at the moment so have tried to connect it directly back to the Vera to see if anything had changed. Initially I just got an error message saying something like “connect RFXTRX to the LAN” and RFXTRX settings showed all protocols at an unset state. I checked the Vera USB settings and they all seem to have been reset to defaults. I set them as per the quick start guide and did a reboot. The settings now look correct for my device (only AD and Oregon enabled), but it’s back to the earlier problem in that it just says “ERROR: Device not ready” when I try to save the settings, plus I also see “Can’t Detect Device” appearing.

Is there anything else I should try or does this still sound like a USB power issue?

My new powered USB hub has arrived. I’ve connected it via that, but unfortunately it doesn’t look any healthier.

I still get a “RFXtrx : Connect the RFXtrx to the LAN” permanent message, plus “Lua Startup Failure.Can’t Detect Device” when I go into the device. When I select RFXTRX Settings I see the list of protocols selected/deselected correctly, but if I try to make any changes I get “ERROR: Device not ready”.

Any suggestions?

Should I delete the RFXtrx device perhaps and try to re-install?

It’s pretty much useless (from a Vera perspective) at the moment.

Did you already fixed your issue? Because I’m having the same problem…

Finally had chance to spend some time with this. I have got it working again, by deleting the RFXTRX device and going through the set-up again. Interestingly, once I had done this, ALTUI started working again - this had also stopped responding.

I still seem to be gettin some LUUP restarts though - will keep an eye on this.

Having the same issue on a Vera PLus

Now resolved this on the VERAPLUS, see that thread. Basically came down to the serial port config getting messed up in my case. Not sure how but it detected the RFXCOM on a second USB port (which does not exist physically…)