Vera Edge has no internet access


Trying to setup a new Vera Edge what a nightmare! Already had the spinning wheel of death and had to use the reset button.

I am now back in the UI but am having issues with the networking setup. In UI7 Settings → Net & Wifi under Internet Access it says No Internet Access.

If I run the trouble shooter this is the result;


=== Testing Gateway: ===

=== Testing DnsServer: ===


=== Testing External Servers ===


STA server: FAILED

EVT server: FAILED
TS server tunnel connection: FAILED

FWD server: FAILED
FWD server tunnel connection: FAILED
== DONE ==[/code]

I currently have “How does Vera connect to the Internet?” set to Automatically Configure (Recommended).

This Vera Edge seems to have two different LAN IP addresses!

As you can see in the trouble shooter output it says its IP is however if I look on my ISPs router its showing that Vera is connected with a completely different IP of

I can ping both these IPs and both in the web browser open the Vera web GUI.

Ideally I wanted to set a static LAN IP on Vera, so I have also tried using the: Manually configure (advanced) option.

In here I set a static IP and turn off the DHCP / Firewall and Wireless options on Vera. But I still have no internet access on Vera and I still end up with two LAN IP’s for Vera. and also the new static LAN IP address I set.

Also please see screen shot attached.

What the heck is going on?


Something peculiar is happening with your Vera’s default route. The diagnostics show that it’s capable of reaching your router at, but that Vera doesn’t know that traffic outside the subnet (to Google, for instance) should be transmitted on the WAN interface.

The virtual “LAN” interface (completely unnecessary on these Veras with only one Ethernet port, a holdover from the Vera3 days when there really were more physical interfaces) seems to be operating on the same subnet, 192.168.0.x/24. That seems wrong. It may be confusing Vera into using the LAN interface for the default route, which goes nowhere because there is no gateway declared for that interface. Also, the doubled 0 is very suspicious. My Vera Lite uses 192.168.81.x/24; perhaps something has overwritten your equivalent of 81 with 00 in the configuration and that’s causing a busted default route. (Or maybe Vera Edge does it differently.)

Fixing it is going to require a shell, probably, or at least getting to the /etc/config/network file where this configuration lives. If you’re not comfortable doing that, perhaps a factory reset might correct it. Otherwise you are going to be calling the support line to have a person talk you through it, I fear.


Thanks for your help.

I did try to use putty to connect via SSH but it always says connection refused when I try using the DHCP IP or the static IP I set.

However I have just tried to SSH in with the spurious IP instead and its working now, however I have no idea what the root password is?

I was going to try and reset it again by holding down the reset button for 30 seconds.


OK I used the reset button again for a second time, the Vera Edge box has picked up a DHCP address of from my router. I can see on my routers admin page that the Vera box is listed as being connected to the LAN (via ethernet cable) with this DHCP assigned IP address etc.

What you said about the virtual LAN interface on the Vera box also using the same 192.168.0.x subnet and it conflicting with the WAN interface makes sense and probably explains what’s going on!

Looking in the Net & WIFI settings now on the Vera Edge box under the WAN section its says its using (DHCP) which is correct.

However in the LAN section of the settings it says IP Address:

Seems this Vera Edge is FUBAR. I am still also running my VeraLite UI5 and all my Z-Wave devices are still connected to that controller. I just got this Vera Edge UI7 two days ago and was going to start transferring everything over to the new controller etc.

I can’t enable the Support Remote access which means I can’t use the trick in the Wiki to discover the root password, which means I can’t SSH in to the Vera Edge box.

Only thing I can think of is to connect the Vera Edge to a router that is using a different LAN subnet that is not 192.168.0.x if it was 192.168.1.x then the Vera Edge might then see the Internet and I can then probably enable the remote support option.

At the moment its a paper weight this unit. :-[

I don’t really know what’s going on on your Vera Edge. My suspicion is that this is DNS related, Vera isn’t resolving the external domain names to IP address and it that problem is frequently due to some sort of issue with DNSmasq on the router.

I would try power cycling your router and then power cycling Vera. If that didn’t work, I would change the router’s DHCP configuration, at least temporarily, to tell clients to use external DNS servers rather than the router itself and reboot Vera again.

If that still didn’t work and you had another router handy, I you might give the other router a try.

I hate contradicting @futzle, but I do not believe that the address is causing any conflict. Having multiple IPs on the same subnet shouldn’t be a problem and these particular subnets are extremely common for Vera installations, so if this was an issue, we would see it a lot. (That IP is a fixed address that is used as a fall back to recover Vera when she gets broken firmware or someone botches the network configuration. It can be changed, but long term you are better off not changing it. There’s just no need.)

The SSH password can be recovered by taking a backup and then looking in the backup file. The file /etc/cmh/cmh.conf contains the password. Frankly, I don’t see any need for you to use SSH at this point.

For setting a static IP address, I would recommend leaving Vera set to DHCP and then creating an IP address reservation for Vera on the router.

Hi thanks for your input.

At the moment I have connected my old router and DSL modem and setup this old router to use a 192.168.1.x subnet instead of the 192.168.0.x subnet.

I have an Internet connection on my laptop and Vera Edge is connected to this old router via an ethernet cable.

At the minute I can connect to the Vera Edge in the browser, its picked up a address from DHCP on the router.

However in the Vera GUI I just get the spinning wheel of death and I cannot click on any of the Vera menus on the left hand side. I am wondering if the reset button thing hasn’t worked properly.

I should also say that initially (for like a day) the Vera Edge was working and did have an internet connection, then this morning when I connected to it via the browser I was just getting the spinning wheel for some unknown reason, so I reset it, this seemed to get me back in to the GUI OK, but it then broke the Internet access and it hasn’t worked since.

And now at the moment I am stuck with the spinning wheel again. ::slight_smile:

OK after a very long time the spinning wheel stopped and it brought up the dashboard first run wizard. Behind this there was a pop up saying
“Failed to save system configuration.”

Looking in the Net & WIFI settings it still has in that LAN section. And it still says No Internet Access.

Attached is a new screen shot of the settings. So it seems changing the router and changing to a different subnet hasn’t resolved the problems.

I now have the root password as well if I need to SSH in to the box.

EDIT: It did briefly say Internet Access OK whilst on the 192.168.1.x subnet / router, but the GUI jammed up again with the spinning circle so I couldn’t then test anything else in the GUI.

The spinning wheel of death is back and I am not unable to do anything in the GUI again.

Giving up should have bought a Fibaro HC2

Will see what support say if anything? I emailed them.

I had similar problems (kind of) with my VeraEdge. I jut got it Yesterday from Amazon.

Once it was powered and connected to my network via Ethernet cable, it took a long time before all lights got lit and steady.
Then I was able to connect to it and successfully went through the steps needed to make it the new primary controller (, taking on from my VeraLite, which was already running UI7. There is a similar article explaining what to do in UI5 as well. The transfer procedure went OK, as verified by the Devices page and the z-wave/advanced page on the Edge. All my devices showed up, the Edge showed as Master and the Lite showed as Slave. So I thought I was in luck.

But it wasn’t to be… The problems started after I restored the backup taken from the VeraLite to the Edge (the last step in the guide above).
The Edge would simply not turn on it’s z-wave led (even though all others were indeed lit) and I was not able to connect to it anymore…

I waited for quite some time (around 60 min) and figured something was botched. So I pressed the reset button for about 40 secs and waited, and waited, and waited more (see a pattern here?) I wasn’t able to ping it’s previous IP address, nor connect to it no matter how I tried. About 2 hours later, I noticed all lights were on again. So I tried to connect to it again via the browser interface and it worked. I was surprised to learn that everything (devices, scenes) was still there! And this time, the z-wave led was on, just like all the other leds.

Bottom line: I’ve learned that, sometimes, with Veras, the best course of action is just to relax and wait until things settle…

SSH into Vera and try pinging an external IP address like I bet it will work.

The next step is to ping a domain name like It should resolve the name to an ip address. If it does not, then you have a DNS issue and should try altering the DNS server as I previously recommended, or buy an HC2.


It pings that external IP but not the domain name for Yahoo.

You said " I would change the router’s DHCP configuration, at least temporarily, to tell clients to use external DNS servers rather than the router itself "

I can’t see any options on my router to do this. I can change the IP and subnet of the router or turn on or off DHCP and also specify a DHCP pool range that’s about it. The router is a BT Home Hub 5 which is from my ISP British Telecom.


Not a Linux expert as you can probably guess LOL, however looking on the Vera box at the /etc/resolv.conf file it contents are:

search lan

Surely the nameserver should be the LAN IP of my router ?

OK I changed the resolv.conf file and added the routers IP instead and the spinning wheel of death then stopped and in Net & WIFI it now says Internet access is OK.

=== Testing Gateway: ===

=== Testing DnsServer: ===

=== Testing DnsServer: ===


=== Testing External Servers ===


STA server: OK

EVT server: OK
TS server tunnel connection: OK

FWD server: OK
FWD server tunnel connection: OK

=== SSH_TUNNELS: ===
Found 1 ssh sessions running
Remote Control Tunnels are running
== DONE ==

Nice. You’ve proven my suspicion that this is a DNS issue. But, despite the seeming effectiveness of your hammer like fix, we don’t yet know exactly if Vera is getting the right DNS server or if your problem is being caused by something else.

Your original /etc/resolv.conf file was correct. I don;t remember if /etc/resolv.conf will survive a reboot.

When using DHCP Vera uses the /tmp/ file for storing the DNS server address. Have a look in there and see if it is properly updated or not.

[quote=“Z-Waver, post:16, topic:189162”]Nice. You’ve proven my suspicion that this is a DNS issue. But, despite the seeming effectiveness of your hammer like fix, we don’t yet know exactly if Vera is getting the right DNS server or if your problem is being caused by something else.

Your original /etc/resolv.conf file was correct. I don;t remember if /etc/resolv.conf will survive a reboot.

When using DHCP Vera uses the /tmp/ file for storing the DNS server address. Have a look in there and see if it is properly updated or not.[/quote]

Had to be too good to be true.

OK looking in the /tmp/ file its contents are:

Interface wan

search home

I just rebooted Vera and its gone again spinning wheel of death is back and Vera says no internet access again :cry:

Looking in the etc/resolv.conf file its gone back to:

search lan

The tmp/ is still pointing to the router IP however.

Interface wan

search home

There is also another resolv.conf file in the tmp directory its contents are:

search lan

So its not remembering the DNS IP address of the router after its rebooted.

Is there a fix to make it persistent ?

Many thanks

As I previously stated, what you are seeing in /etc/resolv.conf is correct. It is not supposed to have the DNS server and it is not supposed to retain changes. It is not supposed to be used as the primary revsolver file.

When using DHCP the DNS server is set in the /tmp/ by the udhcpc process. The DNSmasq process is then supposed to use that and resolve IP addresses for you. Unfortunately, I’m still not sure why it is not working. My suspicion is timing or the Vera clock.

More testing:
After power cycling Vera and finding that it cannot access the internet, again…
Start by verifying if Vera’s clock is set correctly by typing date within a SSH session.

Assuming that the time is correct. Try restarting dnsmasq with the following command

/etc/init.d/dnsmasq restart

I’ll bet it starts working after restarting dnsmasq. At least until the next power cycle. If that is the case, then the issue is almost certainly a delay or impediment in Vera’s ability to acquire the time from the network, which in turn causes dnsmasq some problem reading the /tmp/ file at startup.

How to fix that? It will probably require a change in the way that Vera sets the clock or a delay in starting dnsmasq. But I’m just speculating at this point.