Vera Devices Not Responding After Install

I have just started trying out openLuup and ALTUI. I followed the openLuup setup instructions, installed the VeraBridge and can see all my devices. However, once I do a Luup Reload so that it can load all the icons, it doesn’t look like ALTUI is reflecting the state of my devices anymore. They don’t change when I make a change on Vera. Nor do they control the Vera devices.


OK, Interesting.

You’re not the first to report, and a solution has been proposed (although I don’t have a proper diagnosis yet.)

I’ll update the development branch version and hope this fixes things, while I dig in further…

Apologies for the inconvenience.


1 Like

No worries, just trying some new things with all the free time I have. I assume I should be able to control all the Vera devices and see their updated statuses, yes?

I also tried just using SetTarget under Actions for one my switches and I get “ERROR: No implementation”. I also noticed that any Switchboard Switches on my Vera respond and show updated status perfectly. I also noticed some interesting behavior with the openLuup Reactor plug-in not responding as it should.

Yes, control should work.

I have just updated the development branch for openLuup, so try updating that by typing development into the Plugin pages box against openLuup and hitting the update button.

Here’s what I’m getting in the logs:

2020-04-30 15:54:22.134   openLuup.http:: GET /data_request?id=action&serviceId=urn:micasaverde-com:serviceId:HomeAutomationGateway1&action=CreatePlugin&PluginNum=openLuup&Version=development HTTP/1.1 tcp{client}: 0x55d3824b7538
2020-04-30 15:54:22.134   luup.call_action:: 0.urn:micasaverde-com:serviceId:HomeAutomationGateway1.CreatePlugin 
2020-04-30 15:54:22.135   luup.call_action:: 4.urn:upnp-org:serviceId:AltAppStore1.update_plugin 
2020-04-30 15:54:22.135   luup_log:4: AltAppStore : starting <run> phase...
2020-04-30 15:54:22.135   luup_log:4: AltAppStore : downloading akbooer/openLuup [development] to trash/AltAppStore/
2020-04-30 15:54:22.135   luup_log:4: AltAppStore : GitHub request:
sh: 1: curl: not found
2020-04-30 15:54:22.136   luup_log:4: AltAppStore : error downloading: unknown error
1 Like

Oh no. What machine / OS version are you running this on?

The use of curl was a fix to avoid LuaSocket library version problems. I assumed it was available everywhere. Perhaps the wrong whell is in use?

You can simply update manually by copying all of the GitHub development brach openLuup foler to your own and restarting.

This is the problem with “temporary” fixes! … worked for me, though, it’s not as though I don’t test these things.

I’m using a fresh copy of Ubuntu 20. I updated the files manually and it seems to be working better. I’ll report back if it continues to not work.

SIde note: Any recommended OS to run in a VirtualBox?