VERA BUG Not setting Correct time

I am using the latest firmware (Feb.6).

When I enter my location through the menus, it states the wrong time and the year as 1999…

Anyone know whats causing this?

No idea, mine shows correct time…

HF, Chris
Version 491.

This can be caused by:

  • you have a firewall in front which blocks ntpclient incoming port (123 or 10123). Check if ntpclient it’s running and if not start it manually:
    /usr/sbin/ntpclient -s -c 0 -l -h $HOST -p $PORT

You should forward this port to your vera box. You can use another ntpserver (HOST=“”) or incoming port (PORT=“30123”).
After you find an working ntp server and port put them in /etc/config/ntpclient config file

  • a bug in wifi/ntpclient; check if /etc/config/ntpclient it’s looking like this:

config ntpclient
option hostname ‘
option port ‘123’
option count ‘0’

config ntpclient
option hostname ‘
option port ‘123’
option count ‘0’

config ntpclient
option hostname ‘
option port ‘123’
option count ‘0’

config ntpclient
option hostname ‘
option port ‘10123’
option count ‘0’

config ntpdrift
option freq ‘0’

killall -9 ntpclient
/etc/init.d/ntpclient start

Thanks CJ. I sifted through my firewall and created a special port for the purpose.

Mark-hc. Per the post in the other thread: we just today changed the port to a number >1024. It seems some firewalls block responses to connections when the port is <1024, but with high numbers, it should work

Hmm…okay. I’ve updated to the latest firmware today and I chose to reset to factory defaults because I wanted to start with a clean slate.

Well, once again the Vera router refuses to aquire the correct date and time.

Is Vera changine NTP from its standard default port?

As a default, I block all outgoing connections from my network, and then specifically allow services to go out. I might be only 1% of the home user population that has such restrictive firewall settings. But the fact that Vera isn’t sharing what service ports their using is starting to become a system integrators worst nightmare. Now I have to install Wireshark to see what ports Vera is banging on???


You sound fairly technical, so I’ll toss out this idea: turn on any logging your router supports and look to see what is there from Vera.


What I did to get the correct time is opened up all outgoing ports for a brief moment.After VERA pulled the correct time and date, I shut the ports down again.

I just hate the fact that the router was using certain ports at one moment in time, and now the ports are different. From a system integrators point of view, managing a customers system is a nightmare.

Many customers who have strict firewalls in place ahead of the Vera router are going to be pulling their hair out :slight_smile:
I don’t like guessing games…

Micasaverde team, where can I find a listing of all the ports you are using so I can secure my firewall?

ntpclient use for internet time synchronization port 123 or 10123.
Depending of you firewall you should allow all the communication between your network and our servers and the ports for the ntp sync.

Can’t get it either. Help please. It seems foolish to be able to set time only through your server. How about enabling manual time set or freedom to appoint any of available time servers? Any common IP camera does that, why not MCV?

I have 3G ATT modem plugged into Cradlepoint M1000 router with enabled DMZ plugged into Linksys WRT600n router with enabled DMZ to Vera’s IP address. Also I went to Single Port Forwarding and entered both 123 and 10123 ports , to both external and internal ports, both protocols, to Vera’s IP address, then both lines enabled. Still cannot get it working.

Any detailed advise is appreciated.


I haven’t tried this yet but is going into the Advanced OpenWRT settings and adding an NTP server the same as editing /etc/config/ntpclient by hand? If so, that is a GUI way to point to any ntp server you like, even one running locally on another PC (which could use the PC’s internal clock if your network is down).

Just a thought

You can do that from here:

Modify or add your ntpserver and the port that you would like vera to listen for ntp sysnc.

The port should be UDP. But Vera should have an working internet connection for that to work.
You can enable Tech Support and submit a trouble report and I’ll look to see what could be the problem.