Vera Bricked during upgrade - Please Help!!

Have had a very stable sytem for aomlost a year. Tried upgrading Vera 1 from 979 to latest UI3 so I could use Flash on home desktop and SquareConnect on iPhone and iPad. Now all Vera does is blink and is not found on my home network and I can’t log in. Have unplugged, cleared cache, pressed black reset button twice multiple times. Wiki is not helpful from what I can find past pressing reset button twice. Any ideas before I start submitting trouble tickets, etc? Thanks!!!

I would suggest submitting a trouble ticket now. Might as well start the support clock while you are still trying to resolve on your own.

It happend to me to.

I wrote about it her, but i did not submit a ticket.

If your Vera is V1

What you need to do is a restore of the firmware . Follow the directions. I would suggest not going to UI3 at this point. wait until things are fixed.
Restore to your old firmare and configuration as in the previous post.

make sure you disable the anti virus and unblock the file in windows.

Yes, the phrase “stupid, stupid, stupid…” kept repeating in my head as I went to upgrade. Sounds like I will restore the firmware as suggested and go to .988 which appears to be the minimum required for SquareConnect. Thanks for all the help!!

Am I going to lose my device/scene configurations???

If your going to flash your Vera1 and are using Windows 7 be warned that it will not work. If you have the professional version right hand mouse click over the Rescue.exe icon and choose the Windows XP compatibility mode. Should work now.

I wish I had read this before trying the new UI3 upgrade (1.1.319). I tried the firmware update last night and it failed. I drove down to my vacation house to reset Vera but no go. I tried unpluging Vera and hitting the reset button both with power on and with power off. Nothing works. Vera shows all the lights except for the 2 that are supposed to be on, zwave and Eth1. I have Vera2 and I am using Windows 7. If Windows 7 really is a problem with the firmware upgrade, it would have been helpful for them to put that in the announcement with instructions on how to do it.

Can anyone tell me how to reset Vera so I can get it working again. I have submitted a ticket and e-mailed them, but I don’t have all day to wait around for an answer. :cry:

I had the same thing happen – had to start up an old box I had in the basement with XP on it to get myself out of it. I also had to flash the firmware three separate times to get it right. First time I had problems with sons X-box connecting through Wi-Fi and the second time it had problems connecting to the internet – third time was a charm. Good luck, I understand the frustration. In the middle of this I read the post by gatorbaw and the line – stupid , stupid, stupid rang true in my mind.

If at first you don’t succeed - try, try again

Recovery from Windows 7 worked for me. Cant remember if I used the compatibility mode, but its normally the first thing I try when a windows app doesn’t work, so I probably would have used it!

Vera was working fine on Windows 7 (if you ignore that I had to restart it everytime I hit SAVE). I went through the 1.1.319 upgrade instructions as stated in the announcement, but it never finished. They said it should take 5 minutes. I waited 20, then restarted and nothing. Communication error. I then drove down to the location where Vera is installed (75miles away) and found that Vera was completely frozen with all the lights lit except zwave and eth1. Tried the factory reboot, nothing. I filled out a ticket and emailed them and MCV sent me a file today called an “upgrade tool” with no instructions on how to use it. They said the instructions were in the previous email that I never got. I emailed them several times to send me the instructions, no response. I have a Windows XP machine that I can use to fix it, but I have been waiting since yesterday morning to get this fixed. I have called numerous times and only get voice mail. Now its Friday afternoon and they won’t be around until Monday.

Does anyone have the instructions that go with the upgrade tool? ???

[quote=“robertd202, post:10, topic:165803”]Does anyone have the instructions that go with the upgrade tool? ???[/quote]

Tech support told me the firmware upgrade is independent of the operating system.

“3. How do I upgrade to UI3 with Win7”
"Upgrading the firmware on your Vera doesn’t depend of the OS that you’re using on your PC. "

I can’t seem to get mine to upgrade either. But at least mine is not bricked, yet.


Thanks, but the link you posted specifically says it only applies to Vera 1. Of course, they also provide the links to both Vera1 and Vera2 firmware, so maybe it will work for both and they just didn’t update the page heading. I still have not heard back from MCV so rather than wait till Monday, I’ll give it a try.

Update: Well, that’s a no go. The rescue tool they list on that web page is different from the one they sent me, so I suspect the instructions would be different as well. Besides, they refer to the power light constantly blinking as a sign the firmware is corrupted, but my power light is steady, not blinking. So I guess I better wait till I hear from MCV.

Final Update: MCV sent me a new Vera 2 with 1.0.994 (UI2). Everything is back to normal and working well. I prefer the UI2 interface to the UI3. It is faster and more responsive. However, since I have been beta testing the IVera, I don’t really use the Vera interface except to make system changes or create scenes. Looking forward to UI4.