Vera alerts not working anymore, Failed to save system configuration

I had Vera alerts running for a long time with out any problem. Yesterday I installed a new device, with some issues, but anyway. If I now add new notifications for devices I can not save them.

Every time I go to the tab, I see 2 devices updated. If I leave I see the spinning wheel and then Failed to save system configuration. GOng to the tab again, 2 devices updated. Old notifications are working fine, but not possible to add new ones.

Tried to remove the newly added notification, reload LUA, reboot Vera. Nothing helps.

Yes I saw some old post about this error message, but these are about older versions.

What to do?

Have you checked if you’re out of space? it’s a bit of a guess, though


Yes, loged in already with SSH, 50% free. Never had this before.

You’re looking at the right partition? 50% seems quite a lot unless you’re exrooted…

rootfs is the one


Filesystem Size Used Available Use% Mounted on
rootfs 9.5M 5.9M 3.6M 63% /
/dev/root 9.3M 9.3M 0 100% /rom
tmpfs 61.9M 4.6M 57.3M 7% /tmp
/dev/mtdblock6 9.5M 5.9M 3.6M 63% /overlay
overlayfs:/overlay 9.5M 5.9M 3.6M 63% /
tmpfs 512.0K 0 512.0K 0% /dev
/dev/mtdblock10 64.8M 9.3M 55.5M 14% /storage
/dev/mtdblock10 64.8M 9.3M 55.5M 14% /etc/cmh-firmware
/dev/mtdblock10 64.8M 9.3M 55.5M 14% /etc/cmh-backup
/dev/mtdblock9 7.5M 7.5M 0 100% /mios
root@MiOS_xxxxxxxx:~# free
total used free shared buffers
Mem: 126688 80840 45848 0 0
-/+ buffers: 80840 45848
Swap: 0 0 0

I read somewhere a reply from Richard, to delete all notifications and scenes. And start all over again.
That would be a terrible job. Why is this happening? Could the app not be uninstalled and reinstalled?

Where are you trying to add a Vera Alerts notification?

Into a Vera Scene ?

Last week I added a “new” device, a Virtual motion sensor device and in my PLEG logic I was able to add a notification for Vera Alerts to send out a message when motion is tripped (Blue Iris / IP CAM). That worked OK for me.

I will have to try adding a new Vera Alert notification to a Vera Scene I guess.

I added it for a new device. I also tried to add it to an exciting device. But both give the issue.
Just tried to add a notification to a scene. Went to Vera Alerts, and voila the same error.
So it is impossible to add new notifications. WTF is happening?

I wasn’t aware you could add a Vera Alerts notification directly on to a device? How are you doing that? You have a screen shot ?

I have always added Vera Alerts to either Scenes or in to the Actions of PLEG.

As long as I use Vera Alert (4 years) I use it to set a notification within the settings of the device.
After that I go to the vera alert tab edit, and then you see, xx notification added. Click on close. Done.
But now when I click on Close, I got the error.

Strange I’ve never seen that before where under an actual device you have options for Vera Alerts.

Mine just looks like this lots of white space.

The “Add notification for” drop down menu is for the native / inbuilt Vera notification system, nothing to do with Vera Alerts.

Not true, it works fine with Vera Alert, really. Using it for a long time.

Just try it, at a notification, choose the Vera Alert user. And you will get a notification when you turn on a ligth for example.

OK I will have a look tomorrow and test it.

I will also try adding a new Vera Alert to a scene and see what happens.

Ok this is really weird.

I removed the notification for the latest (new) device. After that I removed the 2 notifications I added lately. There were working fine btw. Then I gave a reboot to the vera.

Then I added 3 new notifications (2 for the same, but other device and 1 for an other device). And they all 3 were working fine, no errors or what ever.

Maybe it was the device with the 2 last added notifications, but I will continue testing tomorrow. Staring to add the smoke detector again.

btw that device where I removed the 2 notifications for, was a coolcam floodsensor, 100% supported by Vera.

Alerts built via the native notification fire in VeraAlerts. Build a native, switch to VeraAlerts, and it will be there…

1 Like