Vera Alerts messages 'stuck' in the system

I have had a few cases now that notifications had not been sent. I know they are working as the have been sent before. So to test i manually triggered a device with notifications attached (which has sent notifications before), nothing goes through to the Android Vera Alerts. I changed a few things in the Vera Alerts device but unrelated to these notifications (i set up email notifications), and all of a sudden i get about 12 notifications in one hit, timestamp actual time, but they had been triggered 10 minutes before, and these were the notifications i was waiting for. Is this normal ? Most of the time (but not always) they come through more or less immediately

Could be GCM related or hitting the quota for the Vera alerts server which isn’t uncommon considering it’s close to the end of the month.

  • Garrett

There are no quotas or limits …

It is related to how often your phone checks in with the Google Servers.
You might have this in some battery saving mode where it minimizes network connectivity time.

Sorry Richard, I thought there was a bandwidth limit.

  • Garrett

I dont think i am on any battery saving mode, i checked my phone and cannot see any of these options enabled. And every night at 2.15 i get the Vera startup message, that is always on time. The weird thing is i clicked on my phone device (i have away and at home both enabled for notification), nothing happened on Vera Alerts. Then my wife left the house, and as soon as her phone jumped from at home to present i had a notification. 10 minutes later i had the notification for my phone. Very strange.
Normally i wouldnt really care that much, but i use tasker and autolocation to tell Vera when we are out or in. That command sometimes does not go through (although confirmed as response ok in authomation). So i have Vera send a notification to my phone when the device has switched. And tasker resend the command until the device has switched. Now that got my phone into a constant loop yesterday as the confirmation never came back… And my phone kept saying ‘Mike is home’ every 3 seconds and did not stop… caused a few giggles though

I’m having a similar issue today, and I can’t seem to figure out why.

Yesterday everything seemed to work fine but today no GCM messages are going thru to my phone, even simple test messages. SMTP notifications still work fine. I’ve reinstalled the Android app on my phone, I’ve restarted my phone, unregistered and re-registered, restarted Vera, pretty much everything but the messages seem to be trapped on the server and not making it to my phone.

Is there anything else I can try to troubleshoot the problem? I’ve tried with my phone on WiFi and 4G, and still no dice. The log seems to show no errors:

08	06/03/14 13:13:10.703	JobHandler_LuaUPnP::HandleActionRequest device: 72 service: urn:richardgreen:serviceId:VeraAlert1 action: SendAlert <0x2e44e680>
08	06/03/14 13:13:10.703	JobHandler_LuaUPnP::HandleActionRequest argument DeviceNum=72 <0x2e44e680>
08	06/03/14 13:13:10.703	JobHandler_LuaUPnP::HandleActionRequest argument serviceId=urn:richardgreen:serviceId:VeraAlert1 <0x2e44e680>
08	06/03/14 13:13:10.703	JobHandler_LuaUPnP::HandleActionRequest argument action=SendAlert <0x2e44e680>
08	06/03/14 13:13:10.704	JobHandler_LuaUPnP::HandleActionRequest argument Message=TEST GCM4 <0x2e44e680>
08	06/03/14 13:13:10.704	JobHandler_LuaUPnP::HandleActionRequest argument Recipients=Galaxy-S3 <0x2e44e680>
08	06/03/14 13:13:10.704	JobHandler_LuaUPnP::HandleActionRequest argument rand=0.5380434026010334 <0x2e44e680>
50	06/03/14 13:13:10.706	luup_log:72: VeraAlert:72:SendAlert:Msg:TEST GCM4 <0x2aeda000>
50	06/03/14 13:13:10.706	luup_log:72: VeraAlert:72:ExpandRecipients:Checking:Galaxy-S3 <0x2aeda000>
50	06/03/14 13:13:10.706	luup_log:72: VeraAlert:72:ExpandRecipients:Adding Requested Profile <0x2aeda000>
50	06/03/14 13:13:10.707	luup_log:72: VeraAlert:72:SendAlert:Sending to:Galaxy-S3 <0x2aeda000>
50	06/03/14 13:13:10.708	luup_log:72: VeraAlert:72:VeraAlertsSend:url:<unique_ID_removed>
50	06/03/14 13:13:11.099	luup_log:72: VeraAlert:72:VeraAlertsSend:Return:200 <0x2aeda000>

Any help is greatly appreciated.


EDIT: After further testing it seems that the issue I’m having is on my Galaxy S3. For whatever reason it cannot receive GCM messages anymore. I downloaded an app to test this and apparently that is the problem. I added my Nexus tablet to use GCM and it works fine so there is no problem with Vera Alerts at all.

EDIT2: I realize this ended up being an Android issue rather than a Vera Alerts issues, but in case anyone else runs into a similar problem as me, my solution turned out to be removing and re-adding my Google account on my phone. This reestablished my GCM ID and then all the “stuck” alerts immediately flooded to my phone.

I still have not been able to find the problem. I can see that the messages are being sent from Vera Alerts device, but sometimes they do not arrive at all, they just ‘disappear’ in nirvana. This happens at differe3nt places, i always check to see if i have 3G coverage and that never is the problem. I occasionally have it in my house too, where i have WiFi coverage. It can be very frustrating when you know you should have received a notification, but it has not arrived. You check, and it haas been sent, just never arrives on the Android phone (I use a Samsung S4 on 4.4.2)
In theroy my setup is working 100%, but because of lost messages i am down to about 80 to 85% reliability which is a shame. I do not think it is the Vera alerts device, as i can see that a message has been sent, and i can see the event has happened. I do not think it is the Android app either, i have the impression the messages get lost somewhere in between. There are other occasions where it takes a long time (10 minutes or so) for the message to arrive, which is another reason i suspect it is lost or held up on the way from Vera to the app.

Any message about exceeding max profiles?

No, nothing about exceeding profiles. I have 2 profiles only, and have a licensed copy. I do not have a huge number of notifications either, somewhere between 10 and 20 per day. But it seems most of the failed messages are in the afternoon or evening.