Vera 2 Troubles

Well, after being talked into the Vera 2 by sales promotion (against my better judgement) I purchased the new unit with UI4. I have been delaying this after Vera worked out all the bugs in UI4. I knew it was going to be a struggle setting up all my scenes and devices so I spent about 6 hours trying to get this thing to work. I had almost everything working last night and then Vera 2 crashed after I woke up this morning. After several attempts to reboot and reset the network, it erased all of my programming. AND decided to re- associate all of my scene/zone controllers for the second time. Out of the box Vera 2 decides to reset all of these devices after I already had then associated, thanks again!!! You need to learn from Controlthink when it comes to scene/zone controller associations. Its a real PITA to setup scenes in vera to get these associations to work.
Thanks Vera 2 for wasting my time!!! Vera 1- 1.0.979 seemed to worked the best for me and is not sluggish like UI4
I am a dealer and have not been convinced yet to sell this product, just too many issues and potential callbacks. This product is nothing more than a remote control and that’s it. Will keep promoting HAI and crestron for the time being until Vera decides to hire someone that can make this product more reliable. The time it takes to get this product to work and potential callbacks exceeds the cost of an HAI or Crestron.
It was of no surprise to me that the UI4 would be trouble…its a shame since this product has some real potential.

Just out of curiosity, do you know if you were running the new Z-Wave 3.20 version?
Also, what was the effect of the “crash” any error messages anywhere?

The reason I ask about 3.20 is that it performs an automatic nightly heal network and reconfiguration of devices that would break associations. Maybe you had red halo’s around the devices?


I was running the new version and I had the scene/zone controllers set to “No” for automatic configure. Last thing I did was remove a motion sensor node from the network and saved. Everything was working until I woke up this morning.

Did you exclude the device or use the trash can?


I excluded the device

All my devices were running on the older Zwave version, not sure if the unit defaulted to 3.2. After reading “MigrateTo452”, I’m pissed this wasn’t mentioned in the documents for existing users.

I’m going to say it was an automatic network heal that did it. Try to repair it yourself and perfom your own and submit a trouble ticket at the same time, the techs will look over your logs and figure it out.

Good luck.


I’m restored and healed, turned off the auto configure and polling. Will see what happens
Some of the scene controls are unreliable like the “turn on” and “turn off after 5 hours”, it must have my memory built in (CRS) ;D

The reason you may have unreliable scenes, particularly the second action that happens after a delay is that the delay action is stored in memory. If Vera is rebooted or I believe if you save data from the UI, the in memory action is lost. It is better to do these delayed actions as a separate scene unless the delay is short.

I have setup scenes in the past to turn off the device due to reliability. My equipment closet is connected to a UPS system so power loss is not the issue. I have experienced this in some of the pre UI4 versions as well. I turned off polling to see what happens. Not sure if polling dumps memory?
Tested for 2 days to no avail and ended up creating the “off” scene which seems to defeat the purpose of having that command.

To add to what @wscannell stated.
I have an “After 3 hrs On” timer which always works but have “After 3 hrs Off” that consistently fails and no reboots or saves interupt it.

So maybe there is a bug here somewhere. I’ll bring it up to the beta testers and MCV as I would like to see the “Duration” timer be the same format as the “Event” timer in that it be infinitly adjustable rather than “preset” times.