USB-fix for Vera Plus? Problems with connecting RFXtrx433E for Somfy control


I am trying to connect my RFXtrx433E to my Vera Plus. To do this, I found and followed the descriptions APNT-79 and -116 on Vesternet. Everything seems to work fine, but in the end I still can’t create devices with which I can control Somfy tube motors. I suspect I need to do the USB fix first. Document APNT-116 has a link to the USB fix, but the relevant page does not seem to exist. I did find something via internet searching, but it seems to be for the Vera Edge, not the Vera Plus (afraid I’ll make my Plus unusable with that fix…). Can anyone help me with the correct USB fix?


If the RFX433E is connected to the USB port you should be able to just set the serial port settings in Apps → Develop Apps → Serial port conficguration. Sometimes after connecting a serial port device it helps to reload the Vera: from your browser: http://[your Vera IP address]:3480/data_request?id=reload
What version of the RFXtrx plugin are you using?

Hi Tinman,

Thanks for your quick response! I did not use an RFXtrx plugin. There is no mention of that in the Vesternet descriptions, and under apps in the Vera Plus I can’t find a plugin with that name either. The Vesternet procedure was: upload a number of configuration files (to “Luup files”, under “Develop apps”), then “Create device” under “Develop apps”, fill in the appropriate xml file in the “Upnp Device Filename” box and then set “serial port configuration”. In the example in the Vesternet descriptions, the path is: “/dev/ttyUSB0”, but for me the “Path” box remains empty. I filled it in manually, but then it disappears again. I suspect that this is the problem and hence I am thinking about the mentioned USB fix. Eventually a device is created with the name “RFXtrx controller device” with which also a new device must be created, which eventually becomes the control panel (device) of the corresponding Somfy motor. But creating that last device does not work. I follow the steps, but nothing is created.

Go to the post here: Plugin Update version 1.97 - Updated!

Hi Tinman,

With the currently latest firmware 1.7.5186 in Vera Plus we have uploaded PlugIn version 1.97.

With that, the RFXCOM (fw227) can be installed and the Somfy devices connected, but then it still doesn’t work properly.

The buttons seem to react randomly and often not at all. See earlier posts by VeraEdger and EllisO, among others, we had exactly the same problem.

VeraEdger describes going back to version 1.87 to get around the problem.

In order not to completely undo the update to version 1.97 with its improvements, we only overwrote two files with the older version,

namely: L_RFXtrx.lua and I_RFXtrx.xml, both from PlugIn version 1.87.

This solves the button problem.

If you manually copy the RFX icon to the correct folder, you will also see an image with the device.

However, in the Protocol settings there is an error message: Error executing function RFX_showProtocols(): firmwareType is undefined

And in the Help tab, the information on the RXFCOM also remains empty.

The MaxMoveTime can be set, but does not seem to function, which is of course possible combined with an old LUA file.

As far as we are concerned these are minor bugs and we are happy that the sunshades are remotely controllable again!

I suggest you upload all the files from version 1.97. The RFXCOM plugin is completely superseded. The error displayed when trying to view protocol settings indicates other things may not work properly as well.

As indicated in my previous post, we initially uploaded all the files from version 1.97 and that gave problems controlling the Somfy motors. We then used two files (L_RFXtrx.lua and I_RFXtrx.xml) from version 1.87 and the problems controlling the Somfy motors were solved. So if we are going to use all the original files from 1.97 again, we will get the same problems again (just tried again…).