Upgrading from Vera2 ssh password are also coming along ..

Maybe this is common knowledge, but for all upgraders, know that the ssh/system password from your old Vera2 gets pulled in from the backup, so the label on the Vera3 back is not working after an upgrade.
At least in my case, I got the old password from the vera 2. Ymmv.

I fixed this by logging into the vera 3 with ssh and entered the vera 3 password with the command ‘passwd’ as I find it good to have the password written on the back.

I do not recall ever experiencing this issue when I restored my Vera 2 onto my Vera 3.

  • Garrett

This just happened to me too. Thanks for your note… using my old PW got me in…

BTW I noticed sometime back you only need to enter the first 8 characters of your password. I discovered this one when I know I “fat fingered” my password but I got in anyway. My new Vera3 does the same thing


I third that. Happened to me after the upgrade as well earlier today.

Easy enough though to SSH into Vera and use the passwd command to reset it to the valiue on the bottom of the unit.

I can confirm this too. I migrated from Vera2 to Vera3 two days ago, tried to ssh into my Vera3 today, but the password from the back on the unit wouldn’t work.
Found this post, tried the password from my old Vera2 and it works.
Thanks for this hint.

So the other thing I noticed is that when I re-set the password with the “passwd” command to the original on the backside of the unit, my 8-character short-cut no longer works. I did a little test and reset the pw to the 1st 8 characters only but then the full pw doesn’t work like it used to. I guess it’s not a big deal. I would have liked to restore it the way it came…