Update failed with critical error!

Trying to upgrade, and I receive the following:
Update failed with critical error! Close this window and go to Advanced > Tech support to contact tech support.

Where is this “Advanced” thing I should go to? This seems to be a braindead error, since if I close the window (the browser window?!) I’ll be looking at my own desktop.

Did you make a backup? If so, do a hard reset of the Edge…wait about 30 mins…seriously, the factory reset takes a very long time. When it is done all of the lights on the unit will be on and ready to be set up like a new unit…you will need to log into your Vera account and reconnect/add the unit back into your account. Then perform the firmware upgrade before doing anything else. When that is completed restore from your latest backup.

Thanks for the suggestion.

Yes, I made a backup.

I’ll give this a try tonight, and hopefully reply back with some good news.

Alas, the same result.

I reset the device via the paperclip-pushbutton, waited for it to come back, and same error.

Hopefully support@getvera will respond.

What ended up happening?

Yep same for me. Will do the factory reset tonight. Never had an issue before :frowning:

Same error here on Vera Lite.
However, after about 15 minutes, mine came back with my setup (devices, scenes, etc.) still intact and back to the old firmware.

Hi,

Same trouble on my Lite (Edge went just fine), but after bricking it because I remove too many files maybe, i reflashed the firmware http://wiki.micasaverde.com/index.php/Firmware_Flash_VeraLite, restored the most recent back up and i seem to be back in business.

Cheers Rene.

O one caveat, you need to have some old laptop running WinXP lying about. ::slight_smile:

Had a brainfart and ran the upgrade on my Vera 3 having forgotten I got the same error updating to the beta of this FW. Not enough space left on the Vera. At least it is still up an running. I’ll see what support can do…

Unfortunately when I logged on to my Vera 3 at my vacation property and it brought me right to the update… so I did it and now it’s offline and I live 325 miles away. And now I can’t program the pin code for the door locks for the upcoming holiday guests. Thanks alot. Gonna cost me 10 hours and 100 bucks in gas just to go up and do a hard reset. I love the system but that’s the last update I’ll do for a long while unless I’m on property. Thanks Micasaverde!

Update… day 3. Still down. I can see the Vera 3 on my router so I know it’s alive anyway. Had my housekeeping service go in and power it off and on. Still same error message. I know the zwave is offline as the lights aren’t coming on at night. MCV support has not gotten back to me despite my several calls to their voicemail (annoying). It’s suppose to be -25 at the house tonight and I’m sitting here unable to monitor (or even increase the heat to combat the cold). Staring at the word “Smarter” at the top of my screen and having a debate with myself. LOL

Support did call back. Nothing they can do without my being with the controller. So off on a 325 mile drive for me. Won’t be updating my firmware remotely… ever again.

I got lucky as my vera3 recovered itself back to the previously installed firmware and is functional. Support did get with me but they are swamped so it may take them longer than normal to get the upgrade done manually. I was told they tweaked the upgrade file to make it smaller. Even with the smaller one, no joy on my Vera 3. Considering she’s running, I am fine with them prioritizing downed units to be recovered first.

Ok… made the 325 mile trek in -12 on icy roads. Of course I DIVED RIGHT IN. By connecting the vera 3 directly to my laptop and putting in it’s internal IP I was able to have it actually try to get into the dashboard. (the dreaded black and red screen is gone this way) but it comes up with an error “LUUP engine is talking longer to load”. My power light is orange, the wifi light is green and communicating but the Z wave is off. I have my latest backup but the RESET doesn’t seem to be working either. So I will try to contact support in the morning and see what happens. I think a cocktail is in order!

I had the same issue and here it is to what I did not hard, and it worked

http://wiki.micasaverde.com/index.php/Firmware_Flash_Vera3

Update: Called support this morning. They logged into my system via a connected laptop and had it all back up and running in about 15 minutes. Pretty sure he just flashed the firmware in. I saw that link above but it clearly says it doesn’t work on win 7 so didn’t even attempt it.

I received an email from support earlier today with some guidelines for my failed upgrade. Note, I have a functional Vera 3 on the last firmware, it just failed with a critical error due to lack of space to do the latest upgrade.

Note: No warranty on following below steps.

  • If you brick your Vera you are on your own.
  • If you don’t feel comfortable, don’t do it and contact support instead

Required: A functional Vera on the last/current firmware with an internet connection

Step 1: Go to Settings -> Backup and click the ‘Create Backup’ button at the top right.
Step 2: Click the ‘Backup Z-Wave Network’ button and wait for the backup to finish. This may take 5 to 10 minutes
Step 3; Click the ‘Create backup’ button and save the file to your local computer hard drive. Make a note of the name and folder location.
Step 4: Go to Settings -> Firmware and click the ‘Upgrade’ button. On the next screen, create a backup of your config and instead of the default ‘keep my settings etc’ select ‘reset to factory settings’ and then start the upgrade.
Step 5. Don’t Panic, all will be well! Go to Settings -> Backup again and check the box in front of ‘Restore Z-Wave network’.
Step 6: Locate the ‘Upload’ button and click it. In the dialog that comes up, locate and select the backup file you created in step 3.
Step 7: Click the ‘Restore’ button and wait till completed. You may have to reload your browser.
Step 8: go to http://home.getvera.com and log in. Then click the ‘Add controller’ link to re-add your Vera to your account. It should have no issues finding it.

After this my Vera 3 was upgraded and fully functional. Of course YMMV (Your Mileage May Vary) and you do these steps at your own risk.