Unable to Upload or Install a plugin

hi @JoseC , @richK we introduced the prefixes for the plugins.

Did you try creating your prefix here first and then udating your config.json file with it. Then try uploading your plugin again pls.

1 Like

Hi @osman How are you? Yes, we have already carried out the process, I attach some gifs of how it was done
plugin
plugin2

1 Like

I get the same thing. Even after defining a prefix, and putting it in the config.json file, I still get the error on upload. Is anyone able to upload a plugin at this time?

1 Like

Only administrators can install and activate plugins on a site. If you are the owner of the website, then you need to ask your developer to make sure that you have administrator permissions.

I am trying to upload my plugin to my account via the mios UI, as described in the instructions. I have no idea what you are talking about when you write about administrator privileges for the website.

Hi @jessica.bullet , @richK
There is no usage like administrator privilige or activate a plugin.
You can check our help documentation on develeoper.mios.com. or we have it posted on the forum MiOS new plugin framework and documentation

It is still not working for me. I was previously able to get the Wake on LAN plugin to upload, but it no longer does. I even added the prefix too the WoL plugin’s config.json file as shown above, and it will still not upload.
I tried the ezlo_protocols plugin also. It failed to upload.

What am I missing? Any suggestions? Does the prefix need to be in the tar file name or something?

@richK it should not be called prefix, give it any name to add it in the litsa of the prefix section, and then put it in all the files,
1-config.json for example : “id”: “security.mqutt” and in the part that says “setitemvaluecommand”: “HUB: security.mqutt…” , “setsettingvaluecommand”: “HUB: security.mqutt…”
2-interface.json for example: “script”: “HUB: security.mqutt…”,
3-scripts example: loadfile(“HUB:security.mqutt…”)
try that way

@andersoncamero Tried this with both the Wake on LAN and ezlo_protocols plugins. Added the prefix as you suggested, and both still fail to upload.

1 Like

Hello @richK

I will double-check once more with the team and the changes that are required in order to upload the plugin, thank you for your comprehension.

@richK This is what needs to be changed in order to upload the plugins

  • config.json
  • interface.json (In case it includes the extension name)
  • Any LUA Scripts that include the extension name
  1. Config.json:

  1. LUA files referenced:

Check the name, label and scripts that include the extension name.

image

Finally add the prefix to the Plugins settings page and then try to upload the tar.gz file.

Let me know if you continue to have problems and if so, please share the plugin if you can.

Still doesn’t work.

This is what I did:

  1. Grabbed the latest version of ezlo_wol from this thread:
    Ezlo - Wake On LAN Plugin is on the marketplace! - #4 by cw-kid
  2. Verified that my prefix was still in the mios Plugin Settings.
  3. Added the prefix to the ezlo_wol/config.json file as shown above. Added the prefix to all “HUB:ezlo_wol” as: “HUB:prefix.ezlo_wol” calls.
  4. Created an updated ezlo_wol.tar.gz file.
    tar -zcvf ezlo_wol.tar.gz ezlo_wol/
  5. Tried to upload the ezlo_wol.tar.gz file (Verify that “MY PRIVATE PLUGINS” is selected. Click the “UPLOAD NEW PLUGIN” button, select new ezlo_wol.tar.gz file, click “UPLOAD TO MY ACCOUNT”).
    Result: “An error occurred while add plugin”.
1 Like

Hi @richK I can help you. can you upload a gif showing the step by step?

Hi @richK

Can you share that same tar.gz file you were trying to upload?

We can check what is happening.

Here is the tar.gz file.

I renamed it so people won’t confuse it with the original. It was named ezlo_wol.tar.gz when I tried to upload it.

Let me know when you have it, so I can remove the link.

I accidentally deleted the file. Here is a working link:

Hello @richK

It’s weird because the config file is there but is not getting recognized as soon as I tried to upload it!

Can you please try with this one? prefix is: ezlo1

ezlo_wol.tar.gz (3.4 KB)

It doesn’t work. I tried it even though the ezlo1 prefix is not in my list (I cannot add the ezlo1 prefix). Same error. I then edited the config.json file and replaced the ezlo1 prefix with my own and tried again. Still the same error.

Hello rick,

Can you please share the error message you receive when attempting to upload the plugin?

You can find it when you try to inspect the page.

  • Under the Network tab
  • Try to upload the plugin
  • At the third request, select it and then open the Preview.

bdbb-11eb-8fb5-1b358695a13b", status: “error”, … }
uuid “5a9515e0-f400-11ec-b8d1-0dcd8285db9b”
location_uuid “b0274630-bdbb-11eb-8fb5-1b358695a13b”
status “error”
status_details “{“errors”:[{“text”:“config.json file not exists”}]}”
timestamp “1656104290”