Unable to upgrade to version #2549

Running openluup v20.5.6 and altui v2.49.2546. Vera3 on the backend. For awhile now whenever I launch the app I get the popup stating a newer version (2549) is available. But after clicking yes the upgrade doesn’t happen. This is from the log:

2020-11-28 12:48:50.132 luup.call_action:: 0.urn:micasaverde-com:serviceId:HomeAutomationGateway1.CreatePlugin
2020-11-28 12:48:50.133 luup.call_action:: 4.urn:upnp-org:serviceId:AltAppStore1.update_plugin
2020-11-28 12:48:50.133 luup_log:4: AltAppStore : starting phase…
2020-11-28 12:48:50.139 luup_log:4: AltAppStore : downloading amg0/ALTUI [2549] to trash/AltAppStore/
2020-11-28 12:48:50.140 luup_log:4: AltAppStore : GitHub request: https://api.github.com/repos/amg0/ALTUI/contents?ref=2549
2020-11-28 12:48:50.148 luup_log:4: AltAppStore : error downloading: unknown error

Same error appears if I try and upgrade from the plugins page.

I looked on github directly and I don’t see any releases past 2545. Maybe that’s the issue but I can’t say for sure. From the evolutions page I get a 404 error if I click “See in github” for both V2546 and V2549. Same issue I expect

Thanks! -D

Sometime @amg0 doesn’t tag a new release. If you simply update from the master branch, you will get the latest. Type master into the Update box on either the AltUI or openLuup Plugins page and click the button.

Thanks, I figured I was missing something simple. That’s probably how I got to 2546


Well, dang. I’m getting the same error with ‘master’:

2020-11-28 14:29:40.354 luup.call_action:: 0.urn:micasaverde-com:serviceId:HomeAutomationGateway1.CreatePlugin
2020-11-28 14:29:40.355 luup.call_action:: 4.urn:upnp-org:serviceId:AltAppStore1.update_plugin
2020-11-28 14:29:40.355 luup_log:4: AltAppStore : starting phase…
2020-11-28 14:29:40.359 luup_log:4: AltAppStore : downloading amg0/ALTUI [master] to trash/AltAppStore/
2020-11-28 14:29:40.359 luup_log:4: AltAppStore : GitHub request: https://api.github.com/repos/amg0/ALTUI/contents?ref=master
2020-11-28 14:29:40.365 luup_log:4: AltAppStore : error downloading: unknown error
2020-11-28 14:29:40.366 openLuup.server:: request completed (148 bytes, 1 chunks, 13 ms) tcp{client}: 0x1769ed8

I tried the URL from the command line and it looks like I got a valid response.


Oh, and it looks like the same error when I try and update openLuup from ‘development’

2020-11-28 14:37:37.650 luup.call_action:: 0.urn:micasaverde-com:serviceId:HomeAutomationGateway1.CreatePlugin
2020-11-28 14:37:37.652 luup.call_action:: 4.urn:upnp-org:serviceId:AltAppStore1.update_plugin
2020-11-28 14:37:37.652 luup_log:4: AltAppStore : starting phase…
2020-11-28 14:37:37.659 luup_log:4: AltAppStore : downloading akbooer/openLuup [development] to trash/AltAppStore/
2020-11-28 14:37:37.659 luup_log:4: AltAppStore : GitHub request: https://api.github.com/repos/akbooer/openLuup/contents/openLuup?ref=development
2020-11-28 14:37:37.666 luup_log:4: AltAppStore : error downloading: unknown error
2020-11-28 14:37:37.668 openLuup.server:: request completed (148 bytes, 1 chunks, 19 ms) tcp{client}: 0x1804238

Maybe I broke something locally. Everything else seems to be working fine though.

I am not talking about upgrading openLuup, but AltUI.

Have you done this from the Alt App Store?

Sorry for being unclear. I appreciate you hanging on with me. I am attempting to update via the More > Plugins page. When I typed ‘master’ into the Update field for Alternate UI plugin as you suggested, and then clicked the update button right next to it, I observed the error described above. Same as when I tried to update via the popup message when opening a browser window to openLuup (which displays ALTUI). My other comment was that I then observed the same error when I tried to update openLuup using ‘development’ (which has worked in the past), indicating to me that the issue is probably not with ALTUI or github at all, maybe it’s something local that snuck in over that last year or so.

I don’t feel that I ‘need’ to update ALTUI. Everything is working great. Very great. But I would love for that popup to go away. Plus some nagging need to ‘try’ to keep up to date. However, there does appear to be a new underlying issue given my lack of success and the errors I see.


Yes, thanks, clearer now, and what I am suggesting is that you try this from openLuup’s Tables > App Store page.

So that was it? I’m unclear why maybe installing an already installed app via the App Store is better or different than upgrading the same via the plugins page. Is there something I don’t know? But I’ll give it a go. --After I backup my containers and volumes. --After I untangle all these christmas lights!! Gaah!

That, at least, is easy to explain. The information required to update an app is stored in the user_data.json file, used by openLuup to save all its configuration. If, for some reason (and it is possible), this data is corrupted, then it can be rewritten by downloading it from the store.

Did this, in fact, fix your problem?