Unable to configure switch and plug

I’m new to Vera so started out slowly. Installed a CT100 thermostat (batt. power) and a Vera Lite. Installation went fine, but got 3 devices when it configured. I installed the MiOS Update Utility and that mostly fixed it (although there are still 3 devices in Homebuddy). I then installed a GE 45609 wall switch and paired it with Vera using full-power inclusion and it worked fine. That setup, with just 2 devices, has been working fine for about 2 weeks.

Today, I finally received my GE 45605 duplex receptacle that was on backorder. I installed it in the same room as the thermostat. I paired it with Vera using full-power inclusion, but the device says “unable to get any information on node.” I’ve tried “configure node right now” with same result. If that wasn’t frustrating enough, the GE 45609 wall switch that has been working fine now also says “unable to get any information on node.” When I try to switch the lights through UI5, it does 5 retries, then gives “Transmit failed with code: 2” message.

So far, the thermostat still seems to be working fine. I have done a heal but the report shows no communication with the wall switch or receptacle.

I’m at a loss where to go from here. I knew Vera would not be the most user-friendly, but this is just unusable.

Thanks for any help.

When you added the new device it introduced a defective route to the Z-Wave network. This is due to weak signal and Vera mistakenly selecting a poor route.

The problem might improve with one or more heal operations, but it will likely return unless you add more nodes and get a better Z-Wave mesh network going. You need more intermediate nodes.

If heals don’t get you working, You may need to remove or relocate the 45605 until you get more nodes.

Edit: I explained and diagrammed what is likely happening to you in this post.

Thanks for the quick reply. So I excluded the 46505 using Vera on batteries, then did a heal, but the wall switch which has worked fine for 2 weeks is still showing “unable to get any information on node.” I have excluded it and included it to no avail. Why would it work fine for 2 weeks, now not work at all? I have attached a screenshot of the heal report.

Thanks again.

I would have expected excluding the 45605 and a heal to mostly resolve your problem. I would suggest removing or relocating, not just excluding, the 45605. Then do a full power include of the 45609. If needed, do a heal after that.

It’s impossible for me you say why exactly this is happening as I have no knowledge of your environment. My guess is that the 45609 is at the fringe of Vera’s range and that the radio frequency(RF) emissions of the 45605 is influencing the signal. But, I can only guess. Adding more (intermediate) nodes is a sure thing.

Thanks Z-waver. Lots to learn about this stuff. The wall switch is about 30-ft. away from the Vera which is on a shelf in an open loft so it’s pretty much line of sight. The 45605 is significantly farther away, but you never know. I am not going to pull out the 45605 as it was a bear to get in (multiple 12-ga. wires did not leave much room in the box). I just ordered a CT100 thermostat which I plan on installing between the Vera and the 45605 and I will hardwire it so that should act as a repeater, yes? I also hope to figure out a way to hardwire the other thermostat in the bedroom which should help also.

Will see how things go when I get the new devices installed.


I’m not experienced with this thermostat, so I may not get this quite rite. But, it is(can be) battery operated. Battery operated Z-Wave devices rarely, if ever, work as routing nodes. This one offers some routing, but not enough to be helpful. Adding an intermediate non-routing node will not help your situation.

When hardwired, the C wire, the CT-100 will function as a proper routing node that even supports Beaming. But, it must be powered by the C wire at the time of inclusion. Adding the C wire after inclusion will leave it in a lesser routing mode.

Most hardwired always-on Z-Wave devices will function as routing nodes, this includes the 45609 and 45605 as well as most GE/Jasco devices.

So I finished rewiring my thermostats today. I first excluded them from Vera, then did the wiring with a “C” wire this time, then added them back to Vera. Since one of these thermostats is in the same room as the 45605 plug, I also added it back. The switch now operates, however when I look in settings for the switch, it is not showing any neighbors. The thermostat also does not show the plug as a neighbor.

Is there a way to verify that Vera knows the thermostat is powered and is acting as a routing node? If the 45605 is not seeing any neighbors, how is it operating?


If the devices are ow working properly, I would not go looking for trouble where it doesn’t seem to exist.

I’d also expect to see Vera displaying neighbors tomorrow, after a 2:00am heal.