UI5 & IP Camera: Archives & Scenes busted, iVera works!

After updating to UI5, I am still struggling to get things to work smoothly as they did in UI4. Here are a couple observations and request for help or ideas to solve!

  1. My Panasonic IP Camera worked perfectly in UI4 with respect to controlling pan, tilt, archiving, and scenes… for example, when viewing camera remotely via MIOS, certain lights would come on…lights and a radio would come on if there was motion detect and then the camera would sent images to the archives…all was good and happy in UI4! (I miss those days that I din’t spend hours messing with basic features of my home automation system!!!..(defeats the purpose of home automation, don’t you think?) )

  2. After upgrading to UI5 on my Vera2, all is not good and I am not happy! Aaah, technology will break your heart! Archives won’t go back past 1 day, nor consistently archive based on my schedule of 1 pic, every hour. Additionally, when viewing the camera via MIOS on my laptop, lights selected to turn on when viewing the camera, do NOT turn on.

  3. When accessing UI5 via my iPhone and iVera, the APP for Vera, lights DO turn on when I view my IP Camera, as selected to do. Archives are not available via iVera…(viewing camera Archives are not yet a feature in iVera)

Why would camera viewing which should trigger lights to come on work via my iPhone APP, iVera and not work via MIOS via my laptop??

Is there a bug in UI5, or why don’t the camera pictures archive on a schedule and visible for more than one day (mine are set to keep pics for 30 days) as they used to in UI4 ?

Any help would be appreciated… I have searched the boards and haven’t really gotten very far. I also have sent in a ticket for Tech Support to MCV, but nothing but the auto reply…nobody home at MCV ??

Thanks for at least reading!


No replies… did I offend anyone?? I would LOVE a bit of a help… just grasping at straws here. MCV has not resounded to my support tickets. Very frustrated. I think it was The Jetson’s cartoon that sold us all on the idea computers and home automation would make our lives easier, save us time. I’m starting to think that George Jetson should have been flogged ! I don’t want to give up on Vera, but this release to UI5 sure has been a pain and has degraded functionality for me.

Hi Drew –

I can’t speak for MCV but suspect they’re overwhelmed at this point with UI5 problems. I don’t understand why the beta testers didn’t identify these problems.

Would suggest you call tech support directly and seek their help. That has been successful in the past. I know you’re not the only one experiencing these problems but I suspect MCV isn’t able to keep up with all of the forum posts. Just a guess.


That is what’s known in rhetoric as “begging the question”.

Drew, it sounds like you were lured into upgrading without a sound reason. In all honesty, unless there’s a feature you need from UI5, your best course of action is to go back to UI4, which seems to have worked for you just fine. This, BTW, is advice that applies to any firmware on any product.

I don’t personally have the equipment that you do, and I don’t use the non-working features that you’ve reported: lights on when viewing cameras and archiving images. So I’m sorry that I’ve only got generic advice.

I don't understand why the beta testers didn't identify these problems.

As a beta tester. There are many reasons why bugs were not found or caught. We do not get every release and MCV does not provide us with every beta build. They release what they think is good for the beta testers to test. We do find many bugs and let MCV know. What they do with that information is on them. There are bugs that we found long ago and have not been fixed yet. MCV decides what the priority of the bugs are and when they can be fixed. Please be kind to us testers. : )

  • Garrett

p.s. UI5 is considered a public BETA build.

Thanks for the feedback everyone, I do appreciate it. I absolutely do understand now that UI5 is a beta. This was not clear to me… Is a shipping Vera 3 with UI5 also considered Beta?? I doubt that my issues are hardware related, so I guess I am going to go back to UI5. I have Vera 2, would upgrade to Vera 3 if I though that would solve the issues. Hard to understand how a shipping hardware product (Vera 3 with UI5) that lots of folks have, would be considered beta. Wouldn’t it make more sense to ship hardware with a supported non-beta release (UI4) ?

When you go to the firmware site, I don’t see any beta warnings anywhere. I would have saved 100 hours or so…

In any event, I love technology, but it sure can break your heart!

Is a shipping Vera 3 with UI5 also considered Beta??
Oh my goodness, yes!

Submitted bug #2051. The reason iVera works is probably because it uses the same HTTP request to view the camera which was used by UI4, but I’m not 100% sure about this.

We checked our database and you have camera archives for the whole January. Which means that it’s something UI related. We’re looking into this.

THANK YOU FOR CHECKING INTO THIS!.. I can only look at the previous day’s archives, which show some pics from the previous day and some pics from current day… each day I look at the archives, it does the same thing. Also, the pics stop showing up in archives after 9:08 AM…

Also, when viewing the camera, I do not get lights to turn on via UI5, but via iVera, the lights do turn on!


After upgrading to UI5 on my Vera2 camera archives won’t go back past 1 day. My settings are: take picture every 3 hour and save them for 3 days. If I check camera archives I can see that today I have 5 pictures (05:24:54/08:24:54/11:24:54/14:24:54/17:24:54, time is now 18:05 Finnish time). But there are no picture before this day. It seems that first picture is always taken about 05:xx. The reason for this is probably that day changes here before “MCV day” and pictures before that time are deleted because they are not taken today. I have not checked the situation between 0:00 and 7:xx (between that time I am sleeping).

Do somebody know how to fix this archive problem/error. It was working before when I had UI4 on my Vera2.

Hello Jukka,

This has been fixed in the latest beta firmware. The public release will be next week at the latest.

Hello mcvflorin

Thanks for the information…

My firmware update page is stating 1.5.254 is still the latest (and exhibits the one day archive problem). I assume the fix is still to be released?


Yes, most probably next week.

I’ve got the same issue on my UI5 Vera3 device - 1 day archive at most. However I’m still running UI4 on a Vera2 - have the cameras loaded in both and they work fine on the 2. Looking forward to the update to fix UI5.

On another note - anyway to redirect where the photos are stored like say to a local device. Or can a person FTP into the server and pull their photos off quickly?

“On another note - anyway to redirect where the photos are stored like say to a local device. Or can a person FTP into the server and pull their photos off quickly?”

I sure would like the ability to do this myself also… like on my own FTP server. Anyone know how ? ???


I can not take pictures with a camera and FOSCAM archive function does not work
like if we can store the archive locally on how to make a synology
thank you

Hello David,
For archiving to work, you need to specify the camera MAC address (camera control panel >> Settings >> MAC).

[quote=“mcvflorin, post:19, topic:170049”]Hello David,
For archiving to work, you need to specify the camera MAC address (camera control panel >> Settings >> MAC).[/quote]

yes thanks