UI4 beta 1

The only problem I have had so far is I cannot change the “Month” to August in the LOCATION Tab. When I select August it and hit the “SET” button it changes back to Janurary. It seems some months work and some don’t. Looks like I can’t use Sunrise/Sunset events for now.

Ditto. Mine keeps reverting back to January as well. Also, it looks like December is missing from the drop down list.

It was only a display issue, the date was properly set to August, but when it was displayed again January appear selected due a Javascript parseInt issue:

Both parseInt('08') and parseInt('09') return zero because the function tries to determine the correct base for the numerical system used. In Javascript numbers starting with zero are considered octal and there's no 08 or 09 in octal, hence the problem.

I fixed the problem (added a second parameter for the base to be used for the conversion) and also fixed the missing month.

I had upgraded a Vera 1 to the latest UI4 (1.1.1047) couple of days ago with no problem. I just received Vera 2 and upgraded it to UI4 per the instruction sheet included with Vera2. This was the first kink as http://micasaverde.com/vera2 as it seems to upgrade the box to an specific version of UI4 and not necessarily the latest version. What this means is that when you try to clone the box you’ll get a message essentially pointing out that you are trying to save a newer configuration file to a box with an older version of the UI4. Unfortunately by the time I caught this it was too late and I had to restart the whole thing. So, if you are doing this make sure you are running the same version of Ui4 on both boxes. That said, cloning the box did not work for me as I kept getting a "Stack overflow on line 1” message. Cloning seems to fail at transferring all the z-wave information as it relates to Schalge lock and any attempt at repairing was unsuccessful so I finally decided it was best to start from scratch with Vera 2 and that seem to have solved most of the problems. I would not however characterize it as a smooth transition. These are some of the issues I’ve noticed;

[ul][li]Date reverts back to January[/li][/ul]

[ul][li]The plugin for GC100 failed to install properly. For one thing it did not see the device on the network and had to be manually configured. Secondly, I had to remove and re-install the plugin multiple times before it actually reported the IR ports. [/li][/ul]

[ul][li]The On button on couple of Leviton lighting switches do not work but if you open up the device and click On from the control panel then it works. The device shows are working properly.[/li][/ul]

[ul][li]Button labels are justified to top of the button and some buttons have a vertical white line before and after the text. OI realize this is esthetic and not a functional issue but nevertheless noticeable.[/li][/ul]

[ul][li]There is no visual cues when you click save so you never know if you are about to interrupt a pending process.[/li][/ul]

[ul][li]This may be an anomaly but it seems to me that Vera 2 runs considerably slower than Vera 1. I can unplug Vera 1 and plug it back in and it would be backup and running under 3 minutes. Vera 2 is taking well over 5 minutes and sometimes hanging all together. Again this may be something that is caused as a result of cloning so we’ll see.[/li][/ul]

[ul][li]Cloning Vera seems to leave scene controllers behind.[/li][/ul]

[ul][li]I could not change SSID when I cloned the box but it worked once I built a new network.[/li][/ul]

[ul][li]I am baffled by this one as MiOS still sees Vera 1 on the network although the unit has been unplugged and removed from MiOS. [/li][/ul]

Finally, I have been very critical of MCV for not communicating with us users in the past. It is obvious that they have been listening. I realize they are implementing a new ticketing system and that will hopefully resolve most of the support issues. But I believe a couple of simple steps may eliminate some of those support calls altogether. There should be a user guide either in hard or soft copy included with each Vera shipped. If not, at least a single online document that can be downloaded without searching through the entire wiki. I realize majority of the information is out there but narrowing down the search is a timely process and when you are in the middle of a problem the last thing you need is to spend an hour on line trying to find an answer to possibly a very simple question. Keep in mind that “simple” is subjective and depends on one’s point of reference and background. I deal with AMX, Crestron, Embedded Automation, VA Automation, RTI, and bunch of other automation products and there is a common thread across most successful products regardless of price. Support and documentation, I don’t need to talk to tech support if I know I can go to someplace and get my hand on the information that I need.


We are trying our best with the tickets. We have the new ticketing system up and running, still running some tests, but it’s looking good… Hopefully in less than a month the impression that we don’t provide support in a timely manner will go away…


Can we get the fixes thus far for firmware .1047 ?


Is anyone else having any problem with GC-100 and IR-devices? I had to try multiple times to get GC-100 plug-in to load properly just so I could see the IR ports. Then I loaded the plug-in for each A/V device and assigned each IR port to a specific device. The problem I have now is that none of the functions are visible and so the remote function is not functional at this point.


[quote=“mcvovidiu, post:5, topic:166378”]Hi,

We are trying our best with the tickets. We have the new ticketing system up and running, still running some tests, but it’s looking good… Hopefully in less than a month the impression that we don’t provide support in a timely manner will go away…


Is the new ticketing system Mantis under bug reporting? I submitted one via the UI4 built-in form which seems to have gone somewhere else. Hopefully all the current support channels are being monitored until everything gets sorted out.

With the built-in email form, it doesn’t seem like there is a way to access your ticket status or send more info. I have tried a number of things on my own that I thought I would forward to support with my original ticket so they have more info and don’t waste time repeating the same tests I tried.

I’m Just wondering if anyone else is experiencing this with Vera 2 running .1047.

Vera is unresponsive if I log in locally or remotely and try to turn on or off more than one light at a time. I is even more noticeable if I can turn on a light, then turn off another light. By the time I get to the third light there is no response and the Mios doesn’t even refresh the screen. Strangely enough if I click on the tool icon then the on/off buttons are fast and responsive.

I finally threw in the towel on .1047 and went back to .1036. Everything seems to work normally now. The only thing wrong is the DATE witch is only surperficial.

I also updated my vera2 from UI2 to UI4. It went OK but I had a couple of problems in the upgrade. After applying the firmware upgrade, I recall that the instructions said to “reset” the vera if there is no response after 15 minutes. At the risk of sounding dense, I think it would be better to instruct users to momentarily disconnect the power since there is no reset switch(?)

After going back to the web page www.micasaverde.com/vera2 during the upgrade process, it says “ERROR, cannot communicate with your vera.” It turns out that if you have it configured with a static IP. the upgrade results in a change back to DHCP. I had to check the mios wiki site for help and ended up hooking a laptop up to eth2 and going to to restore my network settings.

The communications issue is pretty minor and all-in-all, the upgrade went fine. Since I consider myself an advanced noob, I think some people would benefit by some more contingency instructions in case things don’t go quite as expected.

Yes, the month is January and I can’t reset it. Also, there are some device icons that don’t seem to have much purpose. And, my panasonic cameras don’t have a link to view a camera except for wrench icon that would be interpreted as a means of configuring the camera, not just to view it.

On a positive note, the vera is responsive and I haven’t seen delays in operating devices. I have to believe that this major upgrade must be viewed by the developers as a staging for future improvements. They responded reasonably quickly to my questions and listened to my problems - that’s a big plus in addition to the interest that the developers have in upgrading the vera.