Trouble with a ZIR000

I followed the instructions on the wiki but can’t get this sensor to connect. It could honestly be me (or the sensor) so before we get into solutions, is the black wire that runs across the board an antenna or did I receive a bad unit with a wire pulled off the board? Mine has a black wire that isn’t attached at one end, which looks like an antenna but I’ve never seen a z-wave product with a wire antenna before.

If it is, any suggestions on how to get this connected?

I have several wave modules that have an external antenna like that.

Ok. So it’s possible, maybe likely that it’s an antenna…good.

Anyone have any thoughts or had any luck including this in Vera?

Have you tried to exclude it first? Also if you are doing this via battery with a V2 then you might be running into the same problem others are having with inclusion not working. Have you tried through the dashboard with sensor local to vera and seen any error messages perhaps?

I actually run an exclude on everything before I try to include it, I’ve found it to be about 50% necessary but removes 100% of the worries about excluding :wink: I get no error messages, I get nothing (on either include or exclude). I know that Vera sometimes takes a few tries before it sees or includes but I know I’ve pulled the batteries out, plugged them back in, hit full power include and hit the little button on the circuit board a couple dozen times and I get nothing.

I am trying to include it (as with everything) in my office, about 2’ from Vera under Full Power Include. My battery hasn’t worked since UI4 and MCV doesn’t seem to care…so I found a work around.

The work around for things that get installed far from Vera is…I bought a simple plug repair kit ($4 from home depot) and use a piece of Romex and wire the switches or outlet into it, plug it in to an outlet near Vera, exclude/include and wait until Vera is happy it’s on the network and then go install it at it’s appropriate place. Of course this has nothing to do with this problem, just a my work around for anyone that might have the same issue.

Nice solution :slight_smile: I normally just plug my Vera in via a long ethernet cable and use my old V1 as an WiFi to ethernet bridge for anywhere too out of reach of one of my ethernet jacks

Sounds like your unlucky streak is extending to this also :wink: I’d send it back if I was you as it sounds like a dud!

Meh, it’s an easy fix and I’ve learned to have a little thicker skin when it comes to Vera. This is a great forum and if I can come up with creative solutions, just use them and keep going. I really feel like my bad luck has passed, probably just an attitude adjustment but either way I hit a few small bumps, post them here and usually figure them out after a while. I even bought a few Lua programming books, just to be EXTRA dangerous with Vera. Turns out, Lua is basic HTML/Javascripting (maybe a touch of PHP) but it’s all logical and I expect to render my Vera totally useless in no time ;D

I still wish MCV was a bit more honest when it came to its marketing and I steer people away from it if they are higher strung. I talked my dad out of z-wave for his new house and talked him into running cat-6 to every switch/outlet. It’s not cheap but way cheaper while the house is still just studs and gives him limitless options…well almost limitless options. If MCV gets off it’s butt and start putting out updates or at least letting us know about coming updates I might actually start recommending it but…

Ok, I worked this for another hour last night and Vera is simply not seeing it. The sensor is working, it flashes red when I walk in the room, it just won’t connect with Vera.

So here’s a blow by blow so someone PLEASE let me know if I’m missing something.

  1. remove batteries from sensor

  2. set vera to do a full power exclude

  3. install batteries

  4. execute the exclude in vera

  5. hit the little button on the circuit board
    Nothing happens at this point, Vera is trying to exclude but not seeing the device. I have tried hitting the button a couple times during an exclusion but no change.

  6. pull batteries again

  7. set vera to include

  8. install batteries

  9. execute the include on vera

  10. hit the button on the sensor…nothing

I have tried several variations on this, such as don’t remove the batteries, tried low power exclude/include, restart Vera (a few times) and nothing seems to work.

I can accept that I might have gotten a bad sensor but before I totally write it off, I’d like a few more eyes to look at this to make sure I’m not missing a step.