Triggers stopped working

Hi, about 10 days ago something happened, and it seems that triggers stopped working. I’ve got a VeraLite (I think with UI7).

I was out of town, and I eventually noticed that lights weren’t going on/off for the evening after I got back. When I looked at PLEG, I got an error which (as memory serves) was: Error executing function pleg_Inputs(): pleg_Inputs is not a function. This came up when I tried to click Conditions/Inputs, etc.

I couldn’t figure out what to do, so I went into my backups and restored the whole VeraLite to July 7th or so before I left. This backup came from a list of backups that seemed to happen automatically (I only see the list of available backups when I’m logged in - this is separate from the backups I save to my computer when I update firmware).

Still, something is not right and Actions aren’t happening, even when a Condition is true. Example:

  • The condition cDrivewayMotion was true today at 20:17
  • The Action for cDrivewayMotion is to run Scene #62 (turn on a light out there)
  • However, the last run time for that scene is back on July 7th

To test, I just went to the Action list and clicked “Do it Now,” which worked (the light came on, and Vera updated the scene’s last run time).

I’m sure I’m missing something simple, but I can’t connect the dots. Any ideas?

Thank you!

PS - The only other thing that seems new is that my Fibaro RGBW controllers won’t keep the names they had. When I restored to my backup, the names seemed to reset to “Brightness,” “Red,” “Green,” etc. I used to have names like “RGBW_PostLight_Red.” I have since renamed all of them, except “Green” which I don’t currently use.

Edited to add: Firmware is 1.7.830
PLEG Current Version: 7.47
PLC Current Version: 8.14

Is your PLEG ARMED ? If it’s not then actions will not run.

Yes as far as I can tell, it should be armed. “Arm” is green and “Bypass” is grey.

So, I’m wondering if there’s a way to get things working again (currently I’m “getting by” with some basic scenes).

I suspect all of the updates lately might be the culprit - not that I understand these things, but I’ve seen comments about the firmware and such.

Can I do a reset to factory defaults, restore with an old backup from before the updates, and leave things alone for a while? Any better ways to get back up and running?

Thanks as always.

You indicated that your triggers were not firing … But the status report shows that triggers have fired on the day you posted the report.

Are you having problems with a specific trigger ? Which One ? Have you tried to deleted and re-create that trigger ?
If you are still having a problem:

  1. Turn on Debugging to it’s OWN log file
  2. Reload LUA
  3. Trigger the device … Note the time
  4. Send the LOG and a NEW Status report.

Thanks Richard. I see that I was being imprecise: the triggers are firing but the Actions were not happening.

For example, the Condition “AfterSunset” happens every day (based on the Schedule “sPorchLightsOn”. However, one of the Actions is to RunScene #29. That Scene has not run since the 19th (I think I ran it manually).

Several of the device actions within that Action might’ve gotten messed up when the Fibaro RGBW device names changed - maybe that would throw the whole Action off. I’ll try working backwards to delete and re-do the Action from scratch, then the Condition, then Schedule, etc to see if that helps. Previously all I did was add the new device actions with the new device names.

Thanks again.

Still Same Debug process.

OK so I tested and think I got this in the log. At 10:36 I started logging, reloaded Luup, and went out to trigger the motion detectors.

I also deleted and re-created the action (and reloaded Luup) beforehand.

The Action is for the Condition cOverNight_BackGateMotion
I triggered tMotion_J and tBackGateMotion
sOvernight is also true at this time

I just refreshed scenes, and scenes # 42 and 60 have not run since July 7th.

Hopefully I did the log correctly - I said Debug in Standalone file, and copy/pasted into a text file. Not sure if I need to delete that file at some point to save space on the device.

Please let me know if I’ve missed anything or can help clarify anything.

Thanks as always.


Just to let you know I have what I think is the same issue. As far as I can tell none of my actions are firing after upgrade, though I have not tested them all individually.

It’s hard to determine what is happening … You have an Inconsistent set of plugins.
You need to have PLEG/PLC/PLTS all on NEXT-GEN (8.xx) or all on the last frozen version before NEXT-GEN (7.xx)

You need to provide all of the details about Versions and Debug Log Files, Status Report, and details about what specific triggers/conditions are not working properly.

Edited to add: ignore the info below, now I’m getting a new user interface for PLEG it looks like. A little bit of patience…

It’s early as I write this, but wanted to mention I don’t know what PLTS is or if I have it. I know I’ve got PLC and PLEG. I just updated all and will run a test. I also have VeraAlerts.

Update: now something’s really broken. I’m getting “Error executing function device_notifications(): pleg_Conditions is not a function” (same with Inputs/Actions). Can’t see any of that stuff anymore. I’ll probably try to go back to factory defaults and use the cleanest backup I have - assuming that’s as easy as I hope it is.

When things do not work as expected, or you make a configuration change on Vera you should always start with the Vera Two Step:

  1. Reload LUA
  2. Refresh your Browser

Success! Ran a test and it fired a scene!

I’m still confused about why I was confused… Probably because I turned off auto update. To make myself feel better I’ll also blame it on MCV for changing the names of the Fibaro devices, which made PLEG delete them (along with me leaving for a week and the versions getting all jumbled was good timing).

Thank you for your help and patience Richard! I’ll test more tonight but I think I’m unstuck after 2 weeks.

Hi Richard

I supplied the debug and report in the thread that I started before posting in this one. Unfortunately mine does not seem as easily solvable. I really hope you can see something as I also cant restore from backup as seems the upgrade deleted them all from the Vera Portal!,38528.0.html