Trigger stopped after update

My motion sensor triggers have stopped responding after the latest update.Reinstalled PLEG and Core.
Log shows “WatchTriggerProperties : InvalidTrigger :tOM1”. A device property for the tripped variable works fine.
I tried reentering them several times.

Edit: Also Device Properties from a multistring variable are not getting updated.
VeraPlus Firmaware 1.7.1975

Can you go to the Advanced Tab for the PLEG that you are having problems with.
Then copy the contents of the Triggers property and post it .

This looks like trigger was not completely defined …

I created a new PLEG device for testing with only one trigger.

From the advanced tab,triggers. [{‘device’:‘877’,‘name’:‘t1’,‘service’:‘’,‘template’:‘1’}]

Just for the heck of it I pasted this from an older PLEG into the triggers.


After changing the device # to the correct one it works!
So, it looks like the editor is not populating the triggers correctly.?

As I set it looks like the trigger was not fully defined …
Did you select all the options ?

Yes. I will attach screen shots of the 2 triggers I just did. This is the trigger info.


The switch added fine but the motion did not.
I really hope this is not me doing something stupid, but I have worked on it for hours trying everything!

I tried triggers from other devices and they work. It seems to only affect Motion sensors.
I have tried changing the EVENT TYPE and it still does not work.
Parameters for motion devices do work.

Thanks, I will look into it.

I found the problem with this. Fix will be released soon.

If only Vera had someone like you on staff Richard!
Top marks!

Great! I have a couple of other small issues, but I am going ti investigate further before I get with you about them.


RTS, You are the best! Motion triggers are now working.
I was going to write this earlier and tell you it was still not working, but after a couple of reboots it started working correctly!

The fix for newly defined motion triggers did not make it into the release … although I did release the change. Still investigating.

Newly defined motion triggers ARE working for me! I just tested it again.

Maybe I should have stayed in bed … They are working for me now … they were not working a few mintutes ago. It was like and old version was running then.

Thats funny! I had to do a hard reboot. Thanks again.

Bill, Richard,

Can you tell me if the fix regarding new motion sensors is already in place?
As i mentioned before i also experienced the issue that no information was coming to the PLEG
After some updates my existing motion sensors start working again, so i thought all issues are solved. But today i added two new motion sensors and here i’m having the same issues.
They work perfect in the standard Vera software, but not in PLEG. (again no last true or false data is received).

Kind regards,


Did you reload LUA after creating your new triggers ?

Hi Richard,
That did the trick, thanks for your quick reply.