Trane Thermostat - UI7

Im having issues with my trane Thermostat. I was able to get it added to my network but cant get the temperature to update for the set point. The Current inside temperature appears to be correct/functioning as well as the mode switch settings.

I added the Thermostat as a generic Zwave device and the Vera detected it as thermostat etc. I’m defiantly a Nob (Electrical Engineer by Trade) at this home automation stuff not clear where to start debugging. I have sent a email to Vera Support, but thought i would cross post here as well.

Running a VeraLite - UI7 - 1.7.619
Thermostat - tzemt400bb32 - 01.01.40 - ZVER0 2.00.9

Only other device on Network is a Yale Door Lock. All devices are line of sight to the gateway.

I’m having the same problem with my new Vera Edge. I have six Trane thermostats. They all worked flawlessly with my now deceased Vera 2. They show up and read on the browser but not on the iOS app and I can’t update the temp settings at all.

Same problem. It says it updates correctly when you make a change on the UI or App, but nothing changes on the unit.

I wonder if its related to the transition away from the two setttings that use to be there for heat and cool on UI5. My old code would seem to update the unit, but any change on the heat or cool setpoint would just hit the ‘standard’ set point, so only the last write would take.

Not sure what is wrong.


Someone got an answer to this problem?
THere is No way this doesn’t work in UI7. I have one and other coming.

When i updated my Vera 2 from U14 to U15 I had all kinds of weird problems. I removed every scene, every device, and then did a factory reset on my Vera 2.
After pairing all my lights and thermostat and creating new scenes everything began working.
Just thought I’d throw this out there.


I have a dozen Trane Thermostats. My Vera 3 controls them. Last season I set up scenes with no problem. This season I can’t create a scene with them – I can’t change the mode in the scene editor nor can I validate the device changes. Does anyone have any ideas?

FWIW, I have no problems with my light switches.

Ok, I could include it using Generic UI7 option, and not 100% sure, but maybe I think at the beginning I could control it. But later I did realize that even if I decrese temperature and UI said COmmeand sent successfully, the thermostat kept the same.
I haven’t don’t anything more, I’m waiting for Vera Support, because I found nothing on this forum.
Once I get answer, I will inform here.

I received my Trane TZEMT400BB32MAA today and added it to my network as a generic device through the Vera web app. I added it to my scenes and it is working just fine. It took a while to get it all set up properly. I can adjust the temps from the web app, from my iPhone app, and from Vera Mate as well.

Yes, it finally worked for me too.
My problem was that I had my Thermostat set to AUTO mode and it seems that it doesn’t work in that mode.
Once I changed it to COOL using the Vera everything started to work again.

Easy if you know.

Thank you,

I ended up creating scenes where the thermostat mode is set to “autochangeover” and the heat and cool set points are defined. But then adjusting the temp changes those auto set points. I too am new at this and have not found a way to set an override temp set point yet.

Ok, i see what you mean. If the mode is in “Auto”, manually adjusting the temperature on the app does not actually change the room temp. :-\

Yes basically if it is in auto, it wont work to set temp, you need to set it in COOL or HEAT.
Then vera works to control it.

[quote=“Experiment, post:12, topic:188064”]Yes basically if it is in auto, it wont work to set temp, you need to set it in COOL or HEAT.
Then vera works to control it.[/quote]

I’m on the BETA Ui7 and in Imperihome App I can set to auto and change both temps. I have stood in front of the thermostat and watched them change.

Only thing I noticed is after I set the high temp (or vise versa) and change the other temp on the APP it seems to change, but on the actual thermostat works correctly.