TP-Link Smart Plug HS110

Newbie question … (Have I wasted my money?)

I have a TP-Link Smart Plug HS110 …

How do I get it added into my VeraPlus version: 1.7.2138?

I have searched this forum on “TP-Link” and HS110 … found nothing on this WiFi plug.

You probably did waste your money. You or someone else will need to figure out how the plug works and how to control it, probably by issuing commands via HTTP URLs. The fact that it works with Alexa tells me that it shouldn’t be too difficult to do.

After figuring out how it works, it will then be necessary to write some code, better yet a plugin, to control the plug from Vera. No one’s done that yet. Perhaps you can.

Greatly appreciate the response!

We pay for education in many ways, I should’ve done more research. The plug still works very well for my purpose using the Kasa app, just not going to be able to monitor/control it from Vera.

I’ll have to depend on somebody else to do that coding … not my forte. :slight_smile:

What would be a good recommendation for an alternative to the HS110 that does work with Vera?

There are several switchable Z-Wave receptacles available including:

GE 12719 Z-Wave Appliance Module, Plug-In

Aeon Labs ZW075-A02 Smart Switch Gen5

Aeon Labs ZW096-A02 Smart Switch 6, Gen5 - Variable LED can

Greatly appreciate the guidance … Thx!

[quote=“Tod, post:1, topic:193678”]Newbie question … (Have I wasted my money?)

I have a TP-Link Smart Plug HS110 …

How do I get it added into my VeraPlus version: 1.7.2138?

I have searched this forum on “TP-Link” and HS110 … found nothing on this WiFi plug.[/quote]
If someone need it here is disscusion

I was also searching for a solution for this, I bought mine before the Vera plus. When I got my Vera Plus I Googled it and oddly Google send me to the Smartthings forum where someone has adapted the api for the plug to work. Needs a Rasperberry Pi as Smartthings won’t use sockets.

Not a programmer but I wonder could it be sideways adapted

Sent from my Vivo XL2 using Tapatalk

Same as me, I bought one, then later on bought myself a Vera Plus.

Worst case is that I can still use the app that comes with it. :slight_smile:

Hey all

I recently bought a couple of these, because I thought there would have to be some sort of plugin to use them within Vera. Unfortunately as you all know, that’s no longer the case …

So I have been doing some googling, and thought I would share what I have found. I haven’t tried it yet, but I plan to soon. From what I’ve seen, I reckon it shouldn’t be too hard to get something working.

Sent from my SM-N950F using Tapatalk


I made implementation file to manage the TP-Link HS1xx plugs with Vera.

Upload the attached implementation file I_TP-Link-HS1xx-Switch.xml to Vera via the Web UI from menu :
Apps->Develop apps->Luup files->Upload

Then you can create the TP-Link HS1xx device using this URL from browser, filling in appropriate values to VERA-IPADDRESS and PLUG-IPADDRESS.


Current implementation is very simple, just on and off functions without any status checking so failures are not detected or handled.

The implementation uses the same Smart Home protocol as this python tool

I tested the vera plugin on Vera Edge using HS100 V2.0 SW version 1.5.4 Build 180815 Rel.121440

Your instructions worked perfectly on my VeraPlus and a HS110. I have never tried to program a Vera, so reviewing your kit is a great first read. Thanks!!!

Thank you @GaryTTirn. This works very well and I acknowledge it is basic without error checking, etc. But, it was exactly what I was looking for! Now I can add my additional holiday light WiFi smart switches to my existing Vera scenes that control various Zwave devices.

Given I am NOT in the IFTTT Beta, I was forced to try various hacks trying to leverage IFTTT via Mail notifications to bridge my Zwave Switches and my TP-Link / Kasa (and SmartLife) WiFi switches. All of those extremely unreliable or had long lags. I am now curious if a similar approach will work with Smart Life controllable devices.

I followed the instructions and Vera created the device for my TP-Link HS100 plug, but it doesn’t seem to do anything. I know for sure that I’m using the correct IP address and my router isn’t set to block any ports or IP adresses. My Alexa and the iOS Kasa app can control the plug, but the device created in Vera does nothing when turned on and off. Is anyone else having this problem?

I would first check the firmware version on the HS1xx. I read from the python tool git commit log the Smart Home protocol was changed in a firmware that was released about 6 months ago.
Old protocol version didn’t encode the actual message length, the new one does.

Current plugin code may not be compatible with the old firmware, sadly I have no way to test if it is or if isn’t. All my HS100 EU plugs have firmware version 1.5.4 Build 180815 Rel.121440 which supposedly is the latest.

You can also check the Vera LuaUPnP-log and search for string “HS1xx” after doing switch on/off. The plug-in code does log basic socket failures, so that should give some idea if the control message sending fails.


I only use my plugs in direct local mode (or via Vera), I have not registered those plugs to be used via TP-Link web service (using the Kasa App for example).
My firewall actually blocks the plugs from connecting to the TP-link web service as those plugs will try to phone home all the time regardless of being unregistered.
My plugs also have static DHCP address, the router will always assign the same IP to each plug. This is actually required for the vera plugin to work.
I don’t think the TP-link web service cares about the plug IP address as it would seem to work with device ids and plugs register to the TP-link web service using the device id.

I planned to enhance the plugin code to add basic error & status checking and possibly other things but things has been bit busy and I needed to prioritize other tasks.

Problem solved. I had the switch set to a static IP address and had the IP address blocked from internet acces, but couldn?t control the switch locally using your plugin. The problem was that when I originally setup the switch, I had done it through the Kasa (TP-Link) app and at that time the IP address wasn?t blocked from internet access in my router. Apparently, this allowed the Kasa app to phone home and enable remote access to the switch, which disabled local only access. I deleted the switch in the Kasa app and reinstalled it with its IP address already blocked from internet access in the router. This blocked the app from phoning home and it didn?t enable remote access. The switch now has local only access and works perfectly using your plugin. Thanks again for your help and for creating a perfect solution to this problem.

Wow, Thanks! it works for me

I had a few plugs that had to be controlled from the KASA App, now I have them all in the same place!

Thank you so much! This is awesome, it finally brings everything together for me. These are way less expensive than Z-wave ones, but they were always outside of my Vera network. I was looking at other inexpensive options for lamps, and didnt want to get some other brand.

Was going to stock up on some more of them, and came across the update which you can fit two in one wall socket:

Does anyone know if this works with the newer version HS103P2?

I guess we have no facts until somebody actually tests the HS103.

There seems to be a python library claiming support for HS103 - [url=][/url].
Considering the library uses the same Smart Home protocol as the Vera plugin, I don’t see why HS103 wouldn’t work just as well as HS100 and HS110.

Would someone send me a copy of this file? “I_TP-Link-HS1xx-Switch.xml”

Looks like the attachment got lost when the forum platform was changed and now xml attachments are not accepted. Here is the file in a zip-package ; (1.4 KB)