Time based meshbot not working

I got an EzloPlus recently to replace my VeraPlus. I have a simple time based meshbot which never triggers. Basically to turn ON a light at 4 PM and turn it OFF 6 hours later. What am I doing wrong?

Firmware version running: and Advanced Scenes: 1.59

Your rules looks correct to me, when you say it never triggers, does it not turn on the light at 4pm?

In the Vera mobile app whilst connected to your Ezlo hub, check the Settings - Unit Settings and that the time zone is correctly set ?

Or maybe try changing your trigger to this:

Help page about Custom Time here.

  • Before – means ‘The trigger is true from midnight until the time you specify’. For example, ‘Before 8 PM’ means the trigger is true from 12.00 AM until 7.59.59 PM.
  • After — means ‘The trigger is true from the time you specify until midnight’. For example, ‘After 8pm’ means the trigger is true from 8.00.01 PM until 11.59.59 PM.
  • Between — The trigger is true between the two times you specify on your given days. For example, between 6 AM and 7 PM. If you set the start time before the end time then you can create a span over midnight. For example between 7 PM and 6 AM will run the trigger from 7 PM till 6 AM the following day.
  • At a time of day – The trigger will become true everyday at the time you specify and remain true until midnight. Combine this trigger with a days of the week trigger if you only want it active on certain days.

Should I use ‘After’ or ‘At a time of day’?

In most cases, we advise users to choose ‘After’ rather than ‘At a time of day’ to safeguard against network interruptions and hardware failures. However, ‘At a time…’ is more appropriate if your action must run exclusively at a specific time and not afterwards. Let’s explain this a little further.

  • If you choose ‘At a time of day’, your controller must be powered-on at the start time for the trigger to become true. If the controller is offline at the specified time then the trigger will not activate. The trigger still won’t go true when your controller comes back online either because the time slot has passed.
  • If you set the same time but use ‘After’ instead, then, when your controller comes back online, EZLogic notices the time range is still valid and turns the trigger true. This means your meshbot scenes still activate as planned, albeit a little later.

As mentioned earlier, you may want to use ‘At a time…’ if you’d rather the action was not run at all if the scheduled time has passed. Take a simple example of a school lunch-time bell. If the controller is down at your set time then the bell won’t go off in either case (whether you use ‘After’ or ‘At a time…’). However, an ‘After’ trigger would make the bell go off whenever the controller came back online (maybe in the middle of the afternoon). ‘At a time…’ would not cause it to do so.

A compromise between these two is to use the ‘Between’ option. This lets you set a window of, say, 5 minutes during which it is valid to run the action.

I just created a Meshbot rule using “Custom Time” and “At a time of Day” and my first action did just happen OK. I have a second action with a 6 hour delay. Will see later if that second action then runs ?

13:52 pm my second action just ran, which is wrong as its not been SIX hours yet.

My rule was set to trigger at 11:45 am so six hours after that should of been 5:45 pm.

This was my second Action with the 6 hour delay selected.


Hello @bztvih ,

As @cw-kid suggested, you could use the Custom time node and the After Value type to achieve the automation you need.

I tested the scenario using the Days of the Week node and a specific time (which you could use as well). Used a lock and added a 15-second delay for the second Action and it worked just fine.

Tried then with 1 minute delay and worked fine again as the logs show:

Unsecured at 10:15

Secured at 10:16

Will make sure about the exact amount of time you are applying there. In the meantime, I’ll reach out privately to get more information about your setup.

Can you test this with a long delay like 6 hours ?


Earlier I edited my trigger to be at 4:15 PM and my second action has just run at 5:45 PM

This is wrong if I have set a 6 hour delay, so something not right with it.

Thanks @cw-kid and @Alvaro_Ochoa
The time on the ezlo was wrong which Alvaro corrected (though the timezone was set correctly). I am assuming Alvaro set the time manually.
The time on the ezlo is still off by a couple of mins (I am assuming ntpd cannot correct this amount of offset).
Is ‘ntpdate’ available for the ezlo? I see that ezlo looses about a minute of time on every reboot which does not get corrected without either ‘ntpdate’ or ‘rdate’. This is a major design flaw. If for some reason the ezlo is powered off for a extended time, automation will stop working because time will be incorrect.
Automation is working - I tested with a 3 min delay to turn OFF the light. The 6 hour delay also worked.
Thanks !!

1 Like