Thermostat help: I can change setpoint okay, but polling and updates do not work

I can successfully change the setpoints of my thermostats 100% of the time. However,
I’m having trouble polling my thermostats (fails most of the time). Furthermore, the Vera 2 doesn’t get status updates when changes are made on the thermostats directly.

I have two Radio Thermostat Filtrete 3M-50 thermostats: one in the Master Bedroom and the second in the Living Room. Both have the U-SNAP Z-Wave module (aisde: these also have the WiFi module which works well, but I wanted to also access the thermostats from my Z-Wave apps). Both thermostats have the C-Wire connected to them, so they have power constantly (they also have batteries for backup). Other than the my Z-Wave controller (MiCaseVerde Vera 2), I don’t have any beaming devices. But since the thermostats have power via C-Wire, I would think that I don’t need beaming devices.

I successfully included the thermostats to my Vera 2’s Z-Wave network. Using Vera 2, I can change their setpoint temperatures without any problems. Changing setpoint works 100% of the time. When I change the setpoint, the Vera 2 successfully changes the new setpoint. The Vera 2 GUI and the thermostats themselves show the new setpoint. So far so good…

The Vera 2 can talk directly to the Living Room thermostat (i.e. the Vera 2, is a neighbor of the Living Room thermostat). The Vera 2 might have to go through a hop to get to the Master Bedroom thermostat (but the latest heal shows that the Vera 2 is a neigbor). Note that I can consistently change the setpoint of both thermostats using the Vera 2 GUI. Response time is quick (less than a second). No problems changing setpoint, so I know there is no communications problem between Vera 2 and the thermostats.

However, I have the following problems which I need help with:

  1. When I change the setpoint temperature using the thermostat itself (i.e. the buttons in the thermostat), the Vera 2 GUI does not reflect the change. Even if I log back into the Vera 2 hours later, the Vera 2 still says the old setting (and room temperature).

  2. Polling both thermostats fails most of the time (like 90% or more of the time). At one point, polling worked every other time with the
    master bedroom thermostat, but now, polling fails most of the time with both thermostats. Most of the time when I poll, my Vera 2 says “Cannot send command to node”. Sometimes, Vera says “Node never responded”. Sometimes, polling works.

The Vera 2 is only about 15 feet from the Living Room thermostat. The fact that I can change the setpoint successfully 100% of the time means Vera 2 can reach the thermostats just fine. I also tried putting the Vera 2 in WiFi mode, and placing it right underneath the thermostat, and I still get the “Cannot send command to node” problem.

Any suggestions? I just received the Z-Wave U-SNAP modules from Radio Thermostat last week. The packaging said “Z-Wave module v. 10 (2010)”.