Switching from UI3 to UI2

I have changed the firmware to version 2, but now I can not get the Vera to find the network. I have tried resetting the device, but I think I’m doing it wrong. What do I need to do? I have read and searched a bunch of post, but nothing is working. The Vera sometimes now has a blinking red light where the power light is. I have wasted SO much time on this UI3 and nothing would work. I don’t understand why they are thinking about UI4 already. It would be nice to have any UI actually work.

Hello nobody know anything about this? I have had this Vera2 now over a week and nothing has worked at all >:( So I switched to UI2 and now Vera2 doesn’t even work. I have called tech support but I guess they don’t answer or call back so I’m sitting here with this paper weight.

I got this from technical support when I was having problems too. This is the version that I’m using and it seems to be working pretty well:

This firmware has a lot of new features/plugins and it's much improved. Read the instructions listed on our wiki page:


…and do exactly like there.

After that, follow this link:


…to clear the cache on your browser.

I did the firmware change, but Vera doesn’t work now. I can’t find out why. I have tried the reset button pressing it twice, but nothing. Btw I have the new Vera2. HELP!!! I’m kinda getting the feeling that this is a waste of our company time to get this product in our Z wave line. MCV any help I have left messages, but after a week of using this and getting nothing I’m completely frustrated >:(

Which UI2 firmware did you load? I know from expreience that 979 DOES NOT work with Vera2. 988 seems to work well. I have a ticket open with support because findvera does not work for me, but everything else is working great.