Switch Association

Dears,
I am trying to associate two Fibaro switches together to replace two way wall switchs.
i added group 2 to each of the switches and selected the other switch checkbox from the list and clicked save.

the issue is, only one of the switches is triggering the other, but not the other way around, am I missing something?

  • I contacted Fibaro support and Vera support, both gave me mixed responses (even among them) and till now it seems they are both not well versed in association, kind of hit or miss solutions.
  • do we need the vera hub to be close to the switches when doing this?
  • I am planing to do the same on MCO switches.

any help will be highly appreciated.

I probably can’t help with the solution but Im interested in what you’re trying to achieve?

Cheers

C

Are both the switches new and on the same firmware. Newer Fibaro’s (z-plus) can have trouble talking to older Fibaro’s (z-wave) unless you set the setting for telling the newer switch not use encryption for direct association. This can also happen if one was included in secure mode and other in unsecure mode. The fix is the same, disable encryption for direct association in the parameter settings.

Please list what version of the Fibaro switches you have. That can be helpful.

I tried both ways,
Case number 1: two Fibaro dimmers 212, i configured group 2 for both but only one worked
Case Number 2: One Fibaro dimmer 212 and one Fibaro Walli Dimmer, the same case, one worked and the other did not.
i tried configuring option no 27 in fibaro 212 dimmer which make all the association traffic unsecure, but that didn’t help, i could not do the same on fibaro walli cause it seems there is no such option in the manual

My advise: buy the same switches. I have been in this boat. Vera support is helpful but will not be able to help you. I ended up with “different firmwares/implementation/the engine of vera/wrong implementation of the device properties (of the other vendor)”, but never the issue is with vera.

I have it working with 2 qubino sets/pairs. But my problem is the “lag” of 2 to 5 seconds… vera should not be any part of this, due to the fact they should be directly associated, but I suspect it is but I cannot prove cause I can’t sniff and understand what really happens on zwave level and if Vera is debet to it.

Hope you will ever solve this. If yes let us know… and maybe Vera support can learn from this topic.

OK, you configuring each one separately right? You put one in Group 2, then go in and hit the check box for the device you want to control. Then you go to the other device put it in Group 2, then go in and hit the check box for the original device. Correct?

For Case 2, which one wasn’t working? Was it the same Dimmer 212 that wasn’t working in Case 1? Maybe that Dimmer is having a hard time getting the signal out. The association table can get corrupted on these devices when you are first trying to configure them, the table might be full or otherwise causing problems. Best first step is to always delete and re-add the device, it is the only way to ensure the internal association table was clean, Vera can’t actually read that table, so is only showing when it knows you set through the UI, it is not showing the actual state of the association table in the device.
So start clean, only set the associates for the two devices you want in sync. I also usually create a backup scene to that will turn off/on the devices just incase the association signal fails.

Also think about how associations work, the two switches are going to talk directly to each other (instead of routing through the vera). Because the Fibaros sit behind a switch in the j-box, and they need to be able to talk directly to the other switch, if the antenna is damaged on one, or is having a hard time getting a signal out to the other switch that is going to be your problem. Just because one switch is strong enough to get to the other doesn’t mean the opposite is true unfortunately.

@slelieveld same recommendation applies, the lag indicates one of two things… the switches are too far apart (so the signal is having a hard time directly going from one to the other), or the switches have bad/old associates in their internal tables, so are sending out a series of commands, not just the one you want. Delete and re-add them to completely clear the table.

@shallowearth, thank you. All this has of course been tried. The devices dont even do it 1 meter apart, same behaviour as 6 meters (other end of room, same room). Some associations are not even removed after exclusion. You must also reset the device itself. To say: been there, done that. And a lot more… none helps.

Edit: some quotes from Vera support… October, November 2018. See the pattern?

Associations go directly from Device to Device, basically as long as the devices involved support that type of association Vera will be able to set it.
If somehow it fails, you should check with the manufacturer of those devices directly as they should know exactly why that association cannot be set or how it should be set between their devices.
Associations skip Vera as they happen at a device to device level.
Let us know if you have any questions and we will get back to you asap.

The issue could be caused by that active bug, even though the Association should be Device – Device, activating Device 1 from/through Vera could cause a chain delay.
We pushed this to our development team, currently we do not have any real ETA, but this should get fixed in one of the upcoming releases.
Thank you. Have a good day!

We currently cannot make any promises related to this Device, device integration is handled by our Project Managers based on the actual priority list. Our team is looking to improve the overall performance and stability of our services/products alongside with device integration and other fixes.
That’s why we do not have an exact date or estimated date for now.
Thank you. Have a good day!

We are focusing on adding as many devices as possible in the list of ‘full supported devices’ and the Fibaro products are definitely in our development roadmap. However, this will require time and development efforts. But please rest assured that we are doing our best to move the things around in accomplishing this objective.
Our product management team is well aware of your feedback and please allow us a little more time to deliver this.
Thank you. Have a good day!

Apologizes for the delay!
When it comes to those Fibaro Models it’s very hard to manage it properly due to the device’s nature as well. We can attempt to fix this by changing the current settings of the device into something different, however, we cannot guarantee that this will work as expected.
Our team is working on all integrations step by step, depending on each device and each situation the process could be short of long, even if it seems as an excuse, it’s actually very hard to integrate a device based on all the requirements from each involved part.
Please Enable Tech Support on your controller and provide us with the Generated String. Let us know if we can test the network and and also let us know if we can test any of the Fibaro devices that you have (FGS223).
Thank you. I’m waiting for your reply!

I’d be interested to see if using another HUB (think Homeseer, HASS- etc) solves the problem?
Associations are very mis-understood and if the Hub is unable to correctly set the Association Group correctly then it will fail.

I got this answer from Vera, but isn’t it strange? I read somewhere that people where able to associate even more than 3 devices together on vera… (I can’t remember where i read that though)
Vera Answer:
Radu (Vera)

Sep 5, 15:52 UTC

Hello Shady,

Please try to create a scene this way since multiple channel association may not work with Vera.

Thank you.

Ok, latest info after the test:
test number one: two Fibaro 212 dimmers: i configured group number 2 on both of them and ticked the checkbox of the other dimmer in the list, it looks like you need to wait a little (aournd couple of minutes) after each change. now both are working fine, if you turn On/Off any of them the other will follow.

Test number two: One fibaro 212 dimmer and one Fibaro walli dimmer, it worked only one way, when the Walli dimmer was controlling the Fibaro dimmer, but it didn’t work the other way. the support team suggested i exclude and re include them and check but they are connected to many scenes do i didn’t do it since i was just doing it as a test and the first test succeed!

I got a strange support message from Fibaro saying it will only work one way, but clearly that is incorrect.

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules