Sunset triggers several hours early

I use sunset to trigger a MeshBot, but it is triggering several hours early. My local time displays correctly in the Dashboard and my installation address is correct. Are there other location/time fields that need to be set and/or is there a way to expose what the controller is using for its Sunset calculation in the logs?


Hello @rickpalo ,

Meshbots based on the Sun state are directly related to the location.
I’d double check the location is properly set. We could also check that for you, I’ll reach out via PM.

To identify the programmed time for Meshbots execution you could use the API tool > Connect to your controller > Under Commands select Custom and run the following call:

    "id": "_ID_",
    "method": "hub.scenes.time.list",
    "params": {}

The response should look like this:


Thank you for the information. Below is what my controller returns. The UTC offset (-0600) is correct, but sunset should be 20:59 local time, rather than the 18:26:00 that is listed.

executionDate: "2023-06-08T18:26:00-0600"
methodName: "isSunState"
sceneId: "6467fd71e881c66e52c09f3b"
sceneName: "Sunset"
1 Like

It turns out my location was wrong. In the app, under More → My Controllers → (select correct controller) ->Unit Settings → Location, is the necessary place to enter the correct location for the controller. Sunset works correctly now.

1 Like