Suddenly lost all conditions and activities in reactor sensors

I have 5 reactor sensors and today I noticed that 3 of them were not working. Checked and found out that all settings were gone. No conditions and no activities! Unfortunately no backup made…

What could be the reason and is there a way to get the settings back?

I´m running the latest version of Reactor and Vera Plus.

All help appreciated.


I have rebooted my Vera and restarted Luup engine.

This has happened to me a number of times. It appears to happen after I delete device. I have been moving all of my Pleg automations to Reactor and noticed this after deleting un-needed Pleg devices. My solution, back up all Reactor sensors after any changes and restore all reactor sensors if any go blank.

I assume you mean 3.4 (the latest released version in the App Marketplace). If so, have you installed the hotfixes for that version? Reactor 3.4 Hotfixes - Reactor - Ezlo Community

I am using Reactor 3.4 and I have not installed the hotfixes.

OK. Please do. I think they’ll help. What country are you in?

Will do. I will report back if I notice again. USA

Yes it is 3.4. Now I have installed the hotfixes. The Logic summary shows the correct hotfix but the footer I´m not sure about. It looks like this:

"Reactor ver 3.4 © 2018,2019 Patrick H. Rigney, All Rights Reserved. Please check out the online documentation and community forums for support.

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:72.0) Gecko/20100101 Firefox/72.0"

Or where is the footer?

Is that the Reactor master device footer, or a ReactorSensor? If the former, take a look at the latter. If a ReactorSensor is still showing plain “3.4” without a hotfix tag, did you hard refresh your browser to force-reload all the JavaScript? Muy importante.

It is ReactorSensor, I have done hard refresh several times. Running Firefox.

Maybe similar case here, I changed some parameters on a Fibaro FGS-223 and for some reason the devices changed name (not sure if the id changed). After that ReactorSensor was corrupt.

Strange though that one of the affected ReactorSensors belonged to another FGS-223 where I didn´t change anything.

Solved, my browser added “txt” to the file after .js so that was the problem. Just removed the “txt” and it worked!

Thanks for all your help!

Reporting that I am still seeing this issue. Just deleted my last PLEG device and Uninstalled PLEG. Afterwards 5 of 15 of my Reactors were blank. I am on Reactor ver 3.4hotfix-19354. No problem restoring a Reactor backup and all are functional.

Update: Just deleted a couple multiswitch devices and no loss of data in Reactor. Maybe it just had something to do with PLEG. Idk. :man_shrugging:

Reporting I just experienced this with one reactor sensor. I don’t know if it occurred before or after I deleted 2 unused plugins. I was able to restore from backup.

This has been covered. It’s a loss of sync between Vera and UI7. Just reboot the Vera and refresh the browser. No need for restore or other actions, which may actually cause additional harm.

Ooops too late already restored. I did do a luup reload and refresh before I restored, but it was still missing. Will keep in mind for future. Thanks!

After I did the aforementioned restore…it was populated as expected…then it later disappeared again. I did soft reboot, and a browser refresh, and it didn’t come back. I did a hard reset and a browser refresh, and it didn’t come back.

What do you recommend? (I have not done another restore, waiting for your feedback)

I have no other advice for you. These are the steps that work for others. Make sure you do a full power off reboot of the Vera. Make sure you do a complete hard-refresh of your browser (not just the regular refresh). You are not really describing any other symptoms of what “disappeared” means (error messages in the UI? warning triangle/trouble mode?), so I have nothing other to go on here. Details matter.

Whoops sorry…details details.

Yes did hard reset (power off), and a complete hard refresh of the browser.

What disappeared were all the conditions inside the reactor sensor. The only thing that remains unchanged is the Name of the sensor, and the name of the 1st condition. Indeed, there is a comment inside which has appeared stating “Welcome to your new reactor sensor”). I always delete this message when I build the new sensor.

As a result, there are no warnings in the UI because it appears nothing is wrong.

This sensor was originally quite large (many conditions and many activities which control TTS based on Geofences and IP status).

And are you restoring from a Reactor backup, or a Vera backup?