Stelpro STZB402+ (Zigbee fails to communicate with EzloPlus)

I use the Ezlo plus controler. Update to last firmware
I bought 2 Stelpro STZB402+ thermostat to control baseboards heaters in my cottage.
Thermostat version 14, Manufacture date 14 march 2019

Since this exact device shows up in the add device ->Thermostat, I bought it guessing it would be well supported.

  • The device pairs OK (either when choosing the STZB402 device or Generic Zigbee) and I can set the temperature but:

  • the room temperature is not updated in the UI and there is a message saying Device fails to communicate showing constantly.

  • The status of the device in the UI turns to the OFF mode after a certain time although on the device itself the status does not change.

I tried Pairing multiple times with same result.

Is this device really Supported? Can I expect an Ezlo plus firmware version that works?

Hello @Franmarch,

Thank you for bringing this to our attention. Would you mind sharing with us your controller’s serial number for us to take a look at this issue? Feel free to dm us this info if you feel so inclined.