SOLVED: Constant VE restarts until I trip my main breaker

Several days ago, my Vera Alerts started going nuts. At 3am, it announced Vera had restarted. Then a few minutes later, again, and again…

I’ve had this happen before, and ultimately what stopped it was dropping power to the house. I have about 30 Aeon Labs micro dimmers and switches installed behind my regular wall switches. At some point one of them goes berserk - though still controllable (locally and through the VE). Trying to figure out which one is causing it is something above my pay grade (and patience level). By tripping the main breaker on the house for 10 seconds, the restarts stop happening.

Does this seem normal? Is it possible that a zwave device gets so borked that it causes Vera to restart so frequently? What was particularly odd was WHEN it started happening - 317am. No one was awake, and no triggers would have occurred to activate any scenes or PLEG routines.

I realize I could post logs or take other more aggressive approaches to troubleshooting this, but before I do that, I was hoping to see what others think about devices needing a power cycle to get Vera to behave again.

If you lack sufficient patience or skill to troubleshoot the problem, then call support.

Obviously it’s not normal for Vera to do this. But, restarts happen. If you look through these forums you’ll see that there are many causes for Vera restarts. The most common are running out of memory and a process running too long. Vera also restarts automatically as part of its nightly heal operations, that could be occurring around 3:00am.

While power cycling the entire house for a quick “fix” may seem appropriate at 3:00am, it’s not going to find your problem. I’d recommend turning off the Vera Alerts notification of restarts, so Vera doesn’t wake you up in the wee hours of the morning. Then at a more civilized time, you can better troubleshoot the issue, if Vera is still restarting.

I’m not convinced that it is a device that is causing your issue, though it might be. I suspect that you are “resolving” the issue by power cycling Vera. If you feel really confident that it is a device, you could try turning off individual breakers until you locate the device and go from there. If it is Vera, as I suspect, then you’ll need to look at Vera’s logs and see what she’s doing prior to the restarts.

Thanks zwaver. My request here was in parallel to having submitted a ticket with Vera support. Coincidentally, they got back to me this Am.

I took a look on the logs and the Lua engine is constantly restarting because the z-wave chip is failing to respond at random times.

Can you please tell me if you have devices that run on the 900 Mhz band , like baby monitors , weather stations or old cellphones ?

If so they will interfere with the Z-Wave network and thus cause your devices to stop communicating with Vera so we advise that you move those devices outside of the z-wave network.

If you don?t have any 900 mhz devices you can reset the z-wave network and the z-wave chip from Settings → Z-Wave Settings → Advanced then exclude and reinclude your z-wave devices.

If you?ll still encounter the same issue we can replace your unit if it?s under warranty (we offer 1 year warranty) and was purchased from an authorized dealer.

I would rather just buy a new Plus and have the system migrated (or chew off my own right arm) than have to ex/include all 50+ devices and rebuild my plegs.

I have no new rf-based devices in my home, and nothing 900mhz at all, so I’m sure it’s not interference.

BTW, when I do a whole house reset, Vera does NOT reset since it’s on a ups. When I power cycle Vera it does not solve the restarts. And after doing the whole house reset last night, restarts began again before sunrise. So whatever it is, it’s getting worse.

To add more details, CS just replied with this jewel:

In order to try to solve the issue you will need to reset the z-wave network and the z-wave chip (from Settings → Z-Wave Settings → Advanced) then exclude and reinclude your z-wave devices.

It?s not possible to use any backups in this case.

However if you wish to keep the current device id?s you can do it using luup code in Apps → Develop Apps → Test Luup code :

In the above code you?ll need to replace the current and the desired device id keeping the above syntax.

If you would buy a VeraPlus and transfer the network to the VeraEdge you will encounter the same issue so you?ll also need to start from scratch.

So, I guess what I don’t understand is this… If the problem is likely failing hardware on the Edge, then why wouldn’t a backup of the existing network/Edge work when transferred to new hardware (either Edge or Plus)? I’ve asked CS this as well. Based on how he responded, either there’s a type-o (I’m not trying to use a new Plus to restore my existing Edge), or something got lost in translation.

I would much rather pay $150 for a new controller, and be able to move everything over from the failing one, than have to rebuild my network and PLEG routines. My time and sanity is worth more than the $150 saved, even if said ‘reset’ and rebuild actually worked.

Just a thought but have you checked the voltage output from your UPS? There may be something there to make the controller reboot.

No I hadn’t checked that, but that’s a good idea. The same UPS is powering my router and a couple of other devices - none of which have issues. Besides, the controller is never actually rebooting/power-cycling - just restarting (luup).

Since my last post, I backed up the Edge, wiped the zwave network, and restored. Problem remained. So, based on the CS explanation that it’s the zwave chip on the Edge (or some interference at the 900mhz band), I rolled the dice and bought the Plus. It arrived this morning.

I restored the same backup to the Plus. After a few initial glitches (i.e. buying new keys for the PLEG and Vera Alerts plugins) it’s up 100%. No one restart so far (beyond those I initiated). BTW, being lazy, I’m using the Vera Edge power supply - so if it was a power stability issue, I think the problem would show again (unless the VP is less sensitive to that).

So it would appear there really was something (hardware?) that got borked on the Edge.

I’ll post back here in as needed. Thanks for the suggestions…

BTW, this Plus is HUGE! It’s about 2.5x larger than the Edge. Not a deal breaker, but talk about a surprise…

Here’s a follow up to let anyone who stumbles across this thread know what ultimately caused my problems.

Despite an enthusiastic initial report that the Plus resolved my crashing, it did not. Within an hour of the last post, the crashing resumed - with a vengeance. I was seeing 10+ restarts in a row, before it ever got back to a stable state. Then minutes later, it happened again.

Despite days of emails with Vera tech support, who suggested the following possibilities after reviewing my logs multiple times:

  1. interference in the 900mhz range
  2. defective z-wave chip in the controller
  3. incorrect parameter 80 (dec 1) settings on all my Aeon Labs dimmers/switches

On several occasions, they asked me to exclude/pair every device on my network. If I would have had the time, I probably would have. Fortunately, I stumbled upon the problem before undertaking a multi-day long rebuild.

About three weeks ago, I purchased and added two of these Everspring appliance switches with power metering. Aside from some basic testing, they were not added to any PLEG routines or scenes.

Right about the time the restarts began to happen, my 19mo handed me one of the appliance modules. It was plugged in to a receptacle in the family room, but nothing was connected to it. One of the dogs had apparently brushed up against it, and knocked it out of the wall (or knocked it loose). When she handed it to me, I tossed it up on top of the HTPC bookshelf, and didn’t give it a second thought.

I saw the ‘cannot connect to device’ error on the Vera dashboard, and figured I’d eventually exclude it, or plug it back it. To Vera TS’s credit, they did ask about that switch - asking me to exclude/pair it. I told them that it was simply unplugged, and it works when plugged in. Still, the error didn’t bother me since I knew nothing was dependent on that switch. WRONG.

Both my Edge, and the subsequent Plus I bought to eliminate a failed z-wave chip (per VERA tech support) really took issue with that error. In fact, that simple scenario, where a properly paired device (with no dependencies) is no longer powered, caused the entire z-wave network to crash.

What is even more frustrating than the fact this can happen, is the fact that Vera tech support, with all their tools, time, and diagnostic capabilities, couldn’t figure this out. This, to me, is like a customer with a Windows PC with unplugged printer, being told by Dell’s top level support that they need to format their hard drive.

Anyway, once I plugged the device back in, I haven’t had a restart in over 6 hours.

Vent over. Thanks for listening.