[SOLVED] Can't Bridge 2 Vera Lites

My second Vera Lite arrive today and despite following this wiki entry and this bridging walkthrough I cannot get either Vera to see the other. I read reports of people having to connect them directly together for them to discover each other but in my case that’s a bit impossible since it’s 2 Vera Lites and they only have 1 eth port each. I did connect them as “close” as I could by having only 1 unmangaed switch in between them, but this did not help.



You’re not alone. I had the same problem…
unfortunately, no good answer on MCV, but they did fix the problem by remote access.

Subsequently, I have bridged two systems manually, by creating a virtual deviceon the ‘host’ machine and assigning the right device file to it, after ensuring that they are, indeed, on the same subnet and can be seen from my browser:

[ol][li]create virtual device APPS → Develop Apps → Create Device[/li]
[li]set device type to urn:schemas-micasaverde-com:device:HomeAutomationGateway:1[/li]
[li]set device file to vera.xml[/li]
[li]set ip to IP address of device you want to link to (ie. the ‘other’ Vera[/li][/ol]

Reload a few times.
Give it a try - I think the worst that can happen is nothing and then you can delete this device.
On the other hand, it might just work.
Reload a few more time just to make sure!

Good luck.

PS: the OTHER thing you need to know about bridging systems is here…

Well I managed to figure it out!!! ;D

So what worked for me was on both Veras, navigate to Setup → Net & Wi-fi and chose Manually Configure, leave everything the same except on the 2nd Vera change the LAN IP address to I then did a reboot of both Veras and followed the walkthrough again. They could see each other within a matter of minutes! It appears to be working as intended :slight_smile:

Now I not sure if the IP change is necessary but it I know on the Vera Lites, the LAN IP is assigned to the physical eth0 interface and the WAN IP (the real LAN IP) is assigned to the virtual eth0:0 interface. In the default configuration, the 2nd Vera just doesn’t get assigned an IP on it’s eth0 interface (eth0:0 still shows the real LAN IP). Maybe something in the MiOS stack doesn’t like the physical eth0 not having an IP?

In any case, I can sleep easy tonight. Things like this can really get under you skin!