Smartphone web interface plugin problem

I’m running firmware version 1.0.979 and when I install the smartphone web interface plugin, it does not reload successfully and shows the following messagens after entering the main page:

Version: 1.0.979
Checking internet connection …
Loading timezones.json …
Loading local database …
Loading sysinfo …
timezones.json loaded
Internet check status: ok
sysinfo.json loaded
Communication error while retrieving local database.

And the only way to get back from that is to restore to factory default with the reset button.
I’ve tried that several times, cleared all browser cache and the problem still happens.
Did that happen to anyone else? I couldn’t find anything on the forum regarding this subject.

Thanks in advance

I’m having exactly the same problem. Any insight is appreciated! But… what reset button? I can’t seem to restore to a prior state either.

Well, it does not reset to a prior state, it will clean up to factory default. There is a small black reset button at the back of the unit next to the antenna and you just press it twice quickly. The power led will turn off and turn on again in a while. It will be up and running again and you would have to configure everything back again (unless you had a configuration backup to restore).

Got it. But I find that whenever I load the Smartphone plugin, the same problem occurs. I then have to do the reset and reload from a backup that did not have the plugin installed.

Bottom line, what’s up with this plugin? I’m using 1.0.979

Sounds like the problem I had about three months ago. Link to the posting is

Hope it helps.

The problem I’m having is that whenever I ‘install’ the Smartphone Web plugin on Vera, I can no longer access Vera. Not locally, not remotely, not via the iPhone. Vera seems to hang, continues to repeat ‘Vera busy, retrying…’ and then times out. If I then do a reset and reload a backup (that does not have the Smartphone Web plugin installed) all is well again.

Something funky with the plugin me thinks. Yet others seem to be using it just fine. I’ve sent several message to MiCasaVerde support but no response yet.

Still can’t get this to work… Would I be far better off just waiting until the new iPhone app from Square Connect is released?


We’ve noticed this problem Friday on some of our customer’s units. I’ve added a bug report for it and we will see what’s causing that.

Would the new beta firmware have addressed this issue? I’m using the new firmware but am hesitant to try the plugin again unless you believe this problem has been addressed there. Any insight is appreciated! Thanks.

I’ve tried a new firmware mentioned on this thread and the web interface plugin started working.

Thanks for the tip – 1.0.994 installed and now the Smartphone plugin is working!