Sitesensor plugin stopped working

Hi Guys, For sometime I have had sitesensor plug installed and it was all working fine until recently, when it stopped working. I was using to get my Tesla battery SOC and other power data to control hot water cylinder etc.

Anyone else has experienced this? I tried uninstalling the plugin and reinstalling but still no luck.


  • Is that a local URL/endpoint or remote/cloud?
  • What Vera device and firmware are you running?

Also, it looks like you’re on an outdated version of SiteSensor.

@rigpapa Thanks for the prompt response.

It is a URL pointing to a local device “Tesla Gateway”. It was set to WAN IP address which used to work fine. I have tried changing that to Local IP address, but still no luck.

I have a Vera Secure and running the latest version 1.7.4971 (7.31).

Cheers, Pranay

You need to update your SiteSensor to version 1.15.

Getting ahead of myself again. Set the SSLProtocol variable on your SiteSensor to “any”

1 Like

My sitesensor says it has the latest version which is 1.14.

Any clue?

@rigpapa You are a legend! It worked! Thanks mate! Much appreciated!

1 Like