simple vizia RF question

Hi all, i’ve posted here once or twice. I love the vera…

Anyway onto my question, I am interested in the Vizia RF emulator, I have installed it and set a port. I looked through the LUA so I can see that the emulator starts a telnet server and i’m assuming i simply telnet to the vera’s IP, on that port, and send simple strings that I would usually send to the VRC0P. (>N1ON)

Here’s my question as I cant find any documentation or discussions on how the plugin works. I have tried a few things:

I tried to telnet while on my LAN (the vera is not my DHCP), and also while I was actually connected to the vera. I cant get the telnet to work on the port I assigned in the emulator. I saw this in my log after rebooting my vera 3:

01 01/22/13 9:58:42.116 LuaInterface::CallFunction_Timer-5 function setupPorts failed [string “-- constants…”]:38: attempt to call global ‘telnetServer’ (a nil value) <0x2c72f680>

I dont think the server is actually starting/listening but I dont know how to fix this. I have a vera 3 with the latest firmware, I also have a vera lite and vera 2, but the vera 3 is my primary.

I’ve also tried sending http requests to the vera using the “telnet” port, but apparently it doesnt work that way either. (EX:>N1ON) (this cant be right but i tried :-[)

I know some of you have got this to work, do I HAVE to use a usb to serial? I was assuming that, with this plugin, I could simply telnet from my windows machine (or whatever) and send simple commands that the plugin would interpret for the vera.

If anyone could shed the least bit of light on this plugin I would great appreciate the response. I have a lot of vera’s so if I need to change things it’s okay, i’m skilled enough that i’n not going to SSH into my vera and start deleting stuff! BTW this community is great :smiley:

edit: I also set an ip address in the emulator as a variable, it didnt work for me

Hey nevermind I think I figured it out. I’m still not sure what the telnet port number is for though. From what i’ve read, telnet is disabled in UI5 by default because the root password is set by default.

So I got a tripp lite usb to serial adapter and followed the guide [url=,1471.msg4910.html#msg4910],1471.msg4910.html#msg4910[/url] to get it going.

Now i’m just going to start testing using my serial cable, i’ll post when/if I get it working.

how did you go with getting this going?