Set Target not working on one vera but working on the other??

OK hopefully you knowledgable guys can help me…

I’ve developed a plugin which includes UI control handled by the set target function of SwitchPower1.
I’m passing values to it such as “1”, “3”, “R”, “C” and all works OK.

I install the same plugin on Vera #2 and all works ok

I defaulted Vera#1 and reinstalled the plugin and all works except the setTarget function…
Its all the same files,
I even copied over the S_SwitchPower1.xml in case I’d edited that without remembering,
I tried reinstalling all the old plugins in case they modified it in some way,
I’ve checked the log on both Veras when dealing with the setTarget request and both look identical.
Ive checked the “” results and both look identical.
When I check the xml (and json) responses from calling the function via HTML it always comes back as OK (on both Veras)
Ive tried defaulting the “broken” Vera (#1) and doing it all again to no avail.

There are 3 differences.
1 - on #2 I used the restore from a previous backup (which incidentally seemed to do nothing) whereas on #1 it is a “regular” default.
2 - on #1 under variables I have an additional entry with name Status (I already have a variable named Status btw which has an expected value) which the value changes to correspond with the target value Im passing to it, whereas on #2 there is no additional variable and it works as expected.
3 - #1 is a Vera Edge #2 is a Vera Plus (although as it was working and actually developed on the Edge I cant see this as being pertinent)

I’m thinking that there is some sort of reference to the set Target as to what o do with it that I’ve missed and have done during development somewhere but I thought the whole point of using set Target was that most of the work was already done you just had to tell it what to do with the new target effectively??

I got 1 hour sleep last night and have been working on this all day today as well and can seemingly get nowhere.

Please help!


Are you saying that you have an additional (second) variable named Status?

If so, what is its serviceId?

I’m not sure - I should only have one but on the advanced>variables page it says ‘Status’ (which is my Status variable) and a second ‘Status’ at the bottom with a value = to what Im supposed to passing via the set target… As ive not specified the second one I’m not sure what the service ID is…

incidentally Ive fixed the problem (although not solved the issue) by loading a restore point (which did what I was expecting this time lol)… So although I have it working, I need to find out where the issue is to fix it for when I (eventually) release the plugin into the world…

Thanks all,