Sensors not displaying status from remote portal

Looking for help or advice on an interesting display issue. When remotely viewing a VL running UI7 via the portal, sensors don’t display their current status. The “default” status of the device or sensor is displayed, rather than the actual status of the sensor. I found a work-around to force the display of the correct sensor status by opening the device’s edit mode, then closing without making a change.

I grabbed a short video capture to easily show the behavior…

The behavior that I see is almost always present at initial login to the portal, but not always…and never from a local LAN browsing session. Sometimes after logging in to the portal and just waiting, the sensors will suddenly display their correct status. I have ruled out a client issue on my side as I have tried FF, Chrome, and IE browsers. WIN7, 8, 8.1, 10, Mac OS, and Ubuntu operating systems. Additionally, this issue is only present on 1 of 2 VL tied to the same accounts. I have installed and tried every UI7 version available through 1.7.619, which is currently installed. I will gladly install a new version if warranted, but as this VL is remote, I prefer to install when someone is present.

Has anyone seen this issue? Any thoughts on how to beat this into working?

Thanks much

I’ve never seen this. My first thought was to try refreshing the page(F5).

This is where it gets weird.

Has this always been the case or is this behavior a recent development?
What’s unique about this Vera Lite compared to the other?
Are they on the same internet connection?
Are they using different paths, such as one using a wireless bridge, to the internet router?

Are the 2 VL’s using the same account and password? Perhaps the sync isn’t write because of that and perhaps the security exchange between the two. You don’t have any older cp.mios account do you?

@Z-Waver, thanks for taking the time to respond. I appreciate your time(here and on the rest of the forum)

Yes, certainly. Force-refresh page, clear cache, cookies, reboot everything twice

Well, good question. Not sure. The VL was installed 1 year ago at the remote house, and there was someone there that used it from the local LAN at the time. It was only 6 months ago, or so, that this issue was noticed. The issue may have been present the entire time, but was unnoticed.

Nothing. probably “less” unique. There are only 3 z-wave devices installed and a couple of other plugins that I have installed on the “main” VL.

No. Two separate physical locations across the state. Separate Internets, LANs, etc. The problem VL is cabled directly to the Verizon DSL modem/router combo box. All filtering has been disabled on the router. It is only performing NAT.

No, same as above. Direct wired ethernet/IP from VL to Modem/Router.

As it seems that the “data”, the sensor’s status, is present via the portal page…just not always displayed, I believe that the issue lies with Vera Control’s servers. I have opened an email ticket with them late today. Just waiting on a response now.

I havent ruled out an issue with the ISP performing some type of caching, filtering, “optimizing”, etc…OR maybe the NSA’s got a dirty TAP somewhere :o

I like your thoughts. The main(working) VL had an old cp.mios account tied to it. The problem VL never did. Yes, I use the same two accounts for the two VLs. You might be on to something though. I made a similar suggestion when I opened an email ticket with Vera Support earlier today.

I’ll let you know what they have to say.

Opening a ticket is the best choice. Only tech support will be able to see if the “delay” is at Vera or at the servers. I think you’ve effectively ruled out all client side possibilities.

I won’t completely rule out the ISP, but Verizon is usually reliable and there aren’t any odd networking quirks like TCP window size and NAT timeouts like some ISPs have. So, I doubt that it’s them. Filthy NSA taps are a whole other matter.

It might be interesting to find out if your Vera Lites are using the same FWD servers. You can find your FWD servers with the URL below.

[quote=“Z-Waver, post:6, topic:190362”]It might be interesting to find out if your Vera Lites are using the same FWD servers. You can find your FWD servers with the URL below.[/quote]

Browser response:

Not sure why this didnt work…I will search the forum looking for more info to the forward servers.

Sorry. The FWD servers and that URL are for UI5. I just realized you’ve upgraded UI7.

Tech support is what you need. But, we’ll all be interested to here the results.