SCHLAGE Connect Smart Deadbolt and EzloPlus

I am considering this ZWave deadbolt for my home. Wondering if anyone has a Schlage ZWave lock running on EzloPlus? Its not inexpensive and installation and rekeying will take some effort. I don’t want to go down this path if I have a problem with EzloPlus.

Questions if anyone knows:

  1. Does it pair with Ezlo.
  2. Does it show up as a lock in the GUI?
  3. Can you lock and unlock from Mios App on iPhone
  4. Can you control it as an action in a meshbot, lock/unlock.
  5. Can you change the keycodes vias EzloPlus
  6. Can you use a code entry (successful match) as a trigger for a meshbot?

Any help appreciated.

I have the Schlage BE469ZP successfully connected to an EzloPlus so I can provide some insights with that device. In answer your questions -

  1. Yes although as I recall I had to move the Ezlo nearer to the lock to get it to pair correctly.
  2. Yes. I use both the old Vera app and the Mios app on an i-phone and it shows correctly there. Also shows as a lock on the Ezlogic web app.
  3. VERY INTERESTING! I used the Mios app to open the lock and it appeared to “do something” but the status DID NOT update to show unlocked status. When I went to Ezlogic and Vera, both showed the door as being unlocked. When I pressed unlock a second time on the Mios app it showed unlocked for 3 -5 seconds and then reverted to locked so there is a BUG here.
  4. Yes
  5. Yes, or at least I have added pin codes via EzloPlus. Typically you can’t edit or delete codes that are entered directly into the Schlage lock but you should be able to edit codes entered viaa Ezlo.
  6. Not sure. I successfully use door status change in a meshbot but not a specific pin code. I see that choice is now in the menu, didn’t used to even be an option. I just tried to write a local meshbot to trigger when a specific pin code is used and notify me but it wouldn’t save it (save box greyed out). I also tried to write a notification meshbot but pin code is NOT an option there. So you may be able to write a meshbot that does some action besides notify when a pin code is entered but I’m not sure.

Hope this helps!

Ezlo team, you should note the issue with Mios status reporting and the lack of ability to notify when a specific pin code is entered.


Thanks for the detailed response. Based on this I’ll be ordering the same lock and installing it later this week.

1 Like

Hello @ram

Upon investigation, we’ve attempted to replicate the issue and found that it occurs with the MiOS app for iPhone when the Background App Refresh is disabled or when the Low Power Mode is enabled. Could you please verify if either of these conditions applies to your case? We have created the ticket and reported it (ECFI-7)

  • Are you using an iPhone or an Android device?
  • What is the version of the MiOS app you are currently using?
  • Is the issue occurring specifically within the devices list, on the dashboard, or is it happening in both locations?

We have also replicated the “Pin code used notification meshbot” bug, and has been reported (ECFI-5) for a resolution.

Rest assured, we’ll keep you updated on the progress. We sincerely appreciate your patience and understanding.

Just FYI on MIOS iPhone app, (not about OP lock issue).

This app rarely reflects the actual state of devices on EzloPlus. It doesn;t seem to refresh properly and its more common than not. As such I find the MIOS app unusable.

Problems in MIOS app I have seen:

  1. Doesn’t refresh and show device state properly.
  2. Tiles on dashboard are just greyed out, no icon for device.
  3. Executing a meshbot by pressing the arrow key before the meshbot name gives error “Sorry, something unexpected happened, please try again later”
  4. Dimmer switch device not controlling device yet works fine in Vera iPhone app controlling EzloPlus. You can move slider or on/off button and not change the dimmer light. Also can show impossible states like 100% on the slider and the switch off.

So Mios iPhone app is available but it is a very weak initial offering. Creates bugs that didn’t exist on Vera iPhone app. Sorry to be the bearer of bad news but the unit level testing is wholly inadequate. Agile sprints need some modicum of unit testing before throwing to the masses.

1 Like

Hello @curiousB

Thank you for your feedback. We have created a report ticket to the developers for further action and resolution (ECFI-7).

I just replicated the iphone status issue tonight. The lock was physically unlocked when I started this troubleshooting.

I closed the lock using the ezlogic web app and the dashboard on the iphone MiOS app reported the status change properly. Opened and closed the lock using both ezlogic and the MiOS app and status changed appropriately each time on the dashboard.
Then checked the devices tab and repeated the process - when I first opened the device list the lock was physically closed but the device tab was reporting open. I used ezlogic to open the lock - no change in the status on the device tab. Used ezlogic to close the lock and again, no change in the status on the device tab of MiOS. Used MiOS to close the lock and the status changed to locked but only briefly (1-2 seconds) before reverting to open status.

Using MiOS on an Iphone
Running version 1.5 of the MiOS app
Background App refresh is enabled
Not in low power mode
Confirmed that the issue is happening only on the devices list

Thanks for paying attention to the forum and picking up these issues!

1 Like