Schlage BE469 Status not returned in custom scene triggered on PIN Entry


I am trying to have a “AWAY” mode Scene, by creating a custom scene that is triggered when in enter a PIN on the lock. I have configured schlage to ask for PIN on lock too. So to differentiate schlage getting locked versus unlocked via the pin, I have put in a LUA code to check lock status and return true or false. But that does not seem to work. When I put the LUA code it does not proceed.

local status = luup.variable_get("urn:schemas-micasaverde-com:device:DoorLock:1","Status",13)
return (status == "1")

I need this so I can have a “COMEHOME” scene which will conditionally run only when I unlock via the PIN.

What could be wrong with this?

Have you tried dumping out the “status” variable to see what it contains?

A good way to dump out variables to a log file is by using the “kwikLog” procedure, as described in the “Conditional Scene Execution” sticky thread:,18679.0.html

Also the phrase “DoorLock:1” seems wrong to me. Shouldn’t it be “DoorLock1”? Don’t have my code base with me right now, so cannot verify this.

Yes, this is the correct syntax.

luup.variable_get(“urn:micasaverde-com:serviceId:DoorLock1”,“Status”, deviceID)


I am trying to log this data, but I am not able to figure out how to access the log. I am using the veraedge via the url. I just cannot access it locally on my LAN. any help with access veraedge on local network?

I simply enter the following into my browser to access the kwiklog:

Substitute your local Vera IP address, of course. Also, Vera is very case sensitive. Be sure that your file name specified above exactly matches the log file name that your used in the Vera function. (The same thing can be said about Vera statements, as noted above.)

Also verify that you have enabled local access to your Vera through the Vera settings.

Thank you for your response.

How do I find the local Vera IP address and how do I enable local access in the vera settings? I have vera edge.

Welcome to the wonderful world of networking!

The easiest way to do this is to pre-assign an IP address to Vera, using your Router interface. Essentially you get your MAC address of your Vera, then specify on your router that Vera’s MAC address is always to a specific IP address.

You will need to get your router manual out. If you need it, see if a friend (or an available 10 year old) with networking experience can help.

I do not have UI7 or an Edge, so can’t help you there.


:). I am a software engineer. So did all these basic things. It still does not seem to work with UI7 and Vera Edge. So there is something more than basic networking to it.