Scheduling heater

Hi people,

I’m trying to setup a heater to turn on only under 3 conditions :

1 - after 5pm from monday to thrusday
2 - after 4pm on friday
3 - only if temperature goes below 17.

In Pleg, I have as input in the triggers tab, a temperature probe (called t1), which event type is “temperature goes below” set et 17.
In the schedule tab, I have “s1” which is from Monday to thursday at 5pm, and “s2” for the friday at 4pm.
Finally in the condition tab, I put : t1 and (s1 or s2)

However, it doesn’t work at all…
Could you please help me to know what I did wrong ?

Thanks for your help !

Did you put any Off times in your two Schedules?

The best way we can help is if you post the report from PLEG’s Status button as a pdf attachment.

Hi Rex, thanks for your quick reply !
I did a screenshot of the status as you’ve requested.

The temperature today was 13 @ 5pm, and nothing happened :-/

Thanks for your help !

Kind regards,


OK, first you need to add some Off times to your two Schedules. Set Off-type to Weekly, use the same Days as for the On time and set an appropriate Off time - 23:59?

Now add a second Condition:

c2 not c1

and give it an Action:

c2 Turn off Heater (SetTarget newTargetValue=0)

Before the modified Schedules work correctly, you will either have to wait until both the Off and then the On times occur or click the Do It Now button in PLEG to force them to the right state.

I’ll try this and let you know.
Anyway, thanks for your help Rex !

Kind regards,


Hi again !
Unfortunatly it didn’t work as expected, as it turned on at 1pm…
Could you explain why the module consider that condition is satisfied ? What did I do wrong ?
Thanks for your help ! (posting the status with modification Rex told me to do)

Kind regards,

A couple of comments.

You turn on in the evening … and you turn off the following morning … so:

  1. The off days for s1 needs to be 2,3,4,5
  2. The off day for s2 needs to be 6

And on the other two days the heat will be totally off.

It appears you have edited s1 and s2 since the state in the report is off but there is no off time.
You can use the Do It Now to toggle the states of s1 or s2 … to get them in the correct state for the current time of day … or to test/simulate your logic.

Instead of a trigger that is coded to trip at 17 degrees … many others import the temperature as a device variable into PLEG (i.e. a number such as 16.3 , 17.2 …)

Then instead of your current:
c1 t1 and (s1 or s2)

You could use:
c1 p1 < ((s1 or s2) ? 17 : 10)

Then instead of being OFF on the weekends and the day … it just lowers the set point to 10 degrees.

Thanks Richard, I will have a look at this and let you know !

Kind regards.