Scene fires OK, but Vera Edge says "Can't Detect Device"

That is just the tip of the iceberg.

The setup:

[tt]Vera Edge |–20ft (6m)–> Linear Siren |–14ft (4m) → Linear Wall Mount Outlet |-- 20ft (6m) → Linear Wall Mount Switch |-- 20ft (6m) → Ecolink Door Sensor[/tt]
[tt] |–14ft (4m) → Ecolinc Motion Sensor[/tt]

Vera Edge 1.7.1707
Linux MiOS_45015360 3.10.34
Construction type: concrete & brick

Everything seems to work fine up to the Linear Wall Mount Outlet (WO15Z-1) and the Ecolink Motion Detector (PIRZWAVE2-ECO).
The next device is a Linear Wall Mount Switch (WS15Z-1). This is where the problem starts.
Most of the time, Vera Edge controller will report it as “Can’t Detect Device”.
The next device is a (battery powered) Ecolink Door Sensor (DWZWAVE2-ECO). Vera sometimes also reports it as “Can’t Detect Device”, and sometimes it shows and works ok, even if the wall mount switch is not detected. I guess it is routing through the wall mount outlet instead.
When the door sensor is detected (or at least, ther is no “Can’t Detect Device” message), it sometimes reports it is open (The distance between magnet and sensor is very small… way inside the max range specified in the manual).
To complete the description, I have a very simple scene which turns on the wall mount switch whenever a motion is detected in the Ecolint Motion Sensor.
The scene runs fine even when the Vera controller says it “Can’t Detect Device”… so how on earth can it send the on command?
The latest firmware (1.7.1707) does not include repair/heal option, since it is supposed to be taken care automatically.
I know that battery powered devices don’t relay signals, but as you can see I have hard-wired devices every few ft
I also know there is a maximum of 5 hops to reach the controller.
So why on bloody earth this simple setup just don’t work. I have been fiddling with it for 2 weeks now, and it doesn’t seem to stabilize.
Vera support has not been of any help.

So basically, the question is what do you recommend to troubleshoot the bloody thing.
I’m a daily Linux user and software developer, and am not intimidated by the command line, so if you have some low level tips, they are more than welcome.

I haven’t found a reliable way to get a network topology matrix, other than taking note of the “altid” and “neighbors” properties on the “Advanced” section of each device.
In my exasperation, I have also tried to “help” establish a sane topology by editing the “neighbors” field… which I am not sure what effect it has if any.

Any help will be very much welcome.

“Can’t detect device” while everything else works seems to be a common theme with the new Veras. It may be a firmware bug or it may be something to do with the 500 series Z-Wave chip. I suspect that it is Vera firmware related, but I can’t tell you what it is. To be clear, the bug is that everything works but Vera reports “can’t detect device”.

You cannot assume routing, no matter how “sane” it may seem to you or how certain that it’s the “only” possible way. RF does lots of unintuitive things since we can’t see the influencing factors. I will say that the distances that you cite could well be an issue if they are through concrete/brick walls, though they should be fine for clear line of sight. But, there are countless factors that could make your environment no problem or completely untenable.

Honeywell/Ademco has a great technical guide that explains Z-Wave’s workings if you wish to learn about it. But, there’s little or nothing you can program or configure to change things. Vera relies on the Z-Wave chips to figure out the routing and there’s nothing exposed in the UI7 GUI that allows you to control the routing. The proper procedure to address range and routing issues is to add node and relocate Vera.

I have posted in the past about triggering a network heal in UI7. This would be a good thing in cases where you have just added a new device or when you relocate any Z-Wave devices on the network.

If your issue is that Vera says “can’t detect device” but everything works, then I would recommend that you treat it as a cosmetic issue and leave it alone. If however, your devices are not working or are not working correctly, then I would recommend re-arranging and/or expanding the network.

Device doesn’t work reliably? What about when you move Vera closer to it? Move Vera or the device so that they are 3 feet apart. Make sure that they work reliably, and start moving them apart until problems arise. (Don’t forget to heal, or allow time for the network to recalculate its routing after relocating Vera or any other devices.)

When you find the distance where communication starts to break down, that might(probably) be your limit, regardless of whether you consider it “sane” or not. It may be that additional nodes could extend that distance further, but it could well be that it is the absolute limit for your device/network.

There are a few scripts on the forum as well as the AltUI plugin that allow you to see a routing matrix or even a visual representation of your network. But, these are informational only. As I said before, you can’t alter the routing in the UI7 GUI and the solution to these issues is the same(add/relocate) no matter what the network map might look like.

Z-Waver thank you for taking the time to respond in so much detail.

This is a cosmetic issue and Z-Waver’s advice is right on; just leave it be. It should be resolved in the next firmware release which should be released in beta form around the end of the month.

Regarding triggering the network heal in UI7 via luup code, that can cause more problems than things it fixes. The network heal function was removed by Sigma (Z-Wave). We are looking into what we can do to give you some of the functionality back.

[quote=“Marc Shenker, post:3, topic:192460”]Regarding triggering the network heal in UI7 via luup code, that can cause more problems than things it fixes. The network heal function was removed by Sigma (Z-Wave). We are looking into what we can do to give you some of the functionality back.[/quote]Thanks for letting me know.

I am about ready to kick this thing to the curb. Every day I wake up and find another module that sporadically responds with “can’t detect device”. Moving things around fixes it for a day or two, then it comes back or moves to another node. I have tons of mesh strength, but it simply is not reliable.

This system is horribly unreliable and reading about others having having the same issues, it’s hard to believe this stuff isn’t fixed… Maybe it cannot be.

This thread is about a cosmetic issue where everything works, but the GUI states that it “Can’t detect device”. If that is what you are experiencing, then I can’t see it as being such a major issue.

If, however, your devices are not working then you are facing another issue. If so, have you tried contacting customer support? That would probably be more effective than the 45 minutes you spent telling us you were fed up and about to toss it all.

Today, I set the polling of my 2 battery sensors to default polling (z-wave polling is set to 60) and I have had NO can’t detect device errors for a couple of hours.