Scene execution - failed attempt to call a nil value

Rather than add to the last topic from a long while back…

Does anyone else (still) get this error? Apparently at random, depending on the last LUA saved? I’m running UI7 latest public on a VeraPlus.

What’s interesting is that I have ZeroBrane and the first statement that should be executed in the scene function is the mobdebug require. However since the debug session doesn’t get started I’m guessing that the issue is somewhere in the Luup engine.

As I have multiple ZRC-90’s the LUA code is easier than (apologies) kludging virtual switches for PLEG (unless anyone has a more elegant method they have working for UI7).

1 Like

one line of code in the scene and it does not work. i get failed attempt to call nil value
to turn on a light device 141
luup.call_action(‘urn:upnp-org:serviceId:SwitchPower1’,‘SetTarget’,{ newTargetValue=‘1’ },141)
i try it with double quote
i had it running and it stopped working

Hello @Domotique12345 ,

Did you replace all single quotation marks with doubles?

luup.call_action("urn:upnp-org:serviceId:SwitchPower1","SetTarget", {newTargetValue = "1"}, 141)

Yes i did
It worked but then stopped working
now i try to figure out from the log file but see nothing helpfull

I just copied and pasted your suggestion and did not work

Is there a chance that’s not the line where the code is failing?
If you can run that line under “Apps” > “Develop Apps” > Test Luup code (Lua) it might be an indication that the issue is somewhere else.
If the problem persists, please send an email to support at

i tried it with “Apps” > “Develop Apps” > and it works

is there something with the scene application ? is there a way to check with log file ?

If your computer and controller are both within the same network, you could use IP_ADDRESS/cgi-bin/cmh/ to read the logs.

IP_ADDRESS: Controller’s IP Address.

With that i see all my scenes in red does that mean something ?

finally found the error it was on line stated by log
but since i did not know how to read it i did not see

Glad to read @Domotique12345