RunLua Not working

For some reason RunLua in all my reactors have stopped working is there a way to enable it via luup code

I assume it is still enabled…

it is currently enabled

Well, gee, man, are you going to keep us in suspense, or are you going to tell us (a) you’ve looked in the Logic Summary for your ReactorSensor and don’t see any error messages there (maybe post it so we can look, too), and (b) look at your LuaUPnP.log file and see if any error messages stand out there? :slight_smile:

1 Like

i dont think its reactor to be fair, i run a lot of lua code throught reactor and not one but all of the stopped working at the same time, i have begun to rebuild my V+ to see if that will fix it so no & sorry its not reactor because all other things work it just skips rhe RunLua part

Still, if you haven’t looked at the Events section of the Logic Summary, that’s a good place to start, because Reactor will log problems with Lua there. It also logs to the LuaUPnP log file, but the Logic Summary is easier to get to, IMO. But that said, you should always check the LuaUPnP logs as well.

In any case, I am pretty sure Reactor would not just “skip the RunLua part” without logging anything. That area of the code, in particular, is very chatty, because so much random can happen there (i.e. people can put anything in a Lua code block, even stuff that isn’t Lua). But it is a little-used part of the product, and although I have my tests, ultimately that only proves it works the way I test it–there may be bugs to be found.

Most often when things go sideways system-wide with Lua, it’s errant code in startup Lua or a scene, which is one of the reasons I wrote LuaView–it brings all the code together in one screen, and uses the ACE syntax-highlighting editor (same one ALTUI uses). It’s hard to troubleshoot startup Lua and scene Lua because Vera makes one big block out of it, so the line numbers have no meaning and it’s often really hard to find the error. In fact, it’s hard to know an error has even occurred, but what you’re reporting is a common symptom.

I would add that scorching the Earth (rebuilding your V+), while it may ultimately be necessary to resolve an issue we can’t isolate, removes the possibility of finding the actual problem (thereby making us all smarter and/or a product better) and a simpler solution for you. At a minimum, any time you have an issue and you’re asking a question here in the Reactor category, just post a Logic Summary right from the get-go. That way, anything else you might do, at least you’ve captured the state of things at that moment for us to see. We may only be looking at chalk marks in the street at that point, but we still may figure out “who done it.”

totally understand but its deeper than that this is the reason why i decided, so i tried to restore it using an old back up but I didn’t do it correctly so, it wouldn’t reload the use data, i would have to transfer the user files like the PK and the cmh.conf and server.conf manually whenever i rebooted so ultimately a rebuild well most of the /cmh files in order to get the gui back even though the unit was still functional. So u just decided this morning to rebuild it

Understood. Good luck. As I always say, take your time, and go slowly. A few minutes between inclusions–sometimes in setting up devices, Vera does several reloads, and if you interrupt it, you’ll have unhappy devices. Pause every few devices, make a Z-Wave backup and then a full backup. That way if things go sideways, you have lots of checkpoints to roll back to and try again.

See you on the other side!

Np , i am actually switching to a new controller same V+ but a new controller so the aaa stuff has changedby the way do u know to upload userdata to the unit i got the zwave network backed up but just need the userdata uploaded

The one time I tried to restore user_data myself, I was not successful and ended up going to a “real” backup. I haven’t spent any time trying to figure it out since.

1 Like

how do i see the Logic summary ?

Tools tab on your ReactorSensor… Troubleshooting section. There’s a link.

*************************************************** REACTOR LOGIC SUMMARY REPORT ***************************************************
   Version: 3.5develop-20008 config 19362 cdata 19305 ui 19349 pluginDevice 442 LuaXP 1.0.1
    System: Vera version 1.7.4150 (pre-7.30) on Sercomm G450 ID nil (unknown); loadtime 1579023710; systemReady 1579023735; ALTUI v2.47; Lua 5.1; JSON dkjson 1.2
Local time: 2020-01-14T12:45:53-0500; DST=0; Oviedo, Florida United States; formats %Y-%m-%d %H:%M:%S
House mode: plugin 1; system 1; tracking on
  Sun data: { "stamp": 2020014, "civdawn": 1579002790, "nautdawn": 1579001049, "sunset": 1579042098, "nautdusk": 1579045370, "latitude": 28.638136, "astrodusk": 1579047081, "longitude": -81.204733, "civdusk": 1579043629, "astrodawn": 1578999338, "sunrise": 1579004321 }
  Geofence: not running

fixed it it was the name of one of my devices … i have an auto generated list that populates in reactor sanbox and the list wasnt generating properly

luup_log:442: Reactor: “Luup Reload Reaktor” (715) aborting scene “root.true” Lua execution at group step 1, Lua run failed: “/etc/cmh-ludl/MySDc_Devices:1: malformed number near ‘215BackDoor’”

That’s how that’s supposed to work! Good job.